Is there any way to disable Magic Mouse scrolling in Photoshop / Illustrator?

Posted:
in Mac OS X edited November 2015
This is driving me nuts?*the new Magic Mouse is so touchy that while I am working in Photoshop or Illustrator, it is constantly shifting the page around.



Imagine you were using the Hand tool, and it was moving left, right, up down at random?



I have been looking for a way to disable this, but can't find anything application specific.



Help!

Comments

  • Reply 1 of 19
    OK so it looks like you just have to turn off both the "One Finger Scroll" and the "Two Finger Swipe" in the Mouse preferences.



    http://img.skitch.com/20100115-s4a5u...5rr9pu2edu.jpg
  • Reply 2 of 19
    If you think the magic mouse is bad then brace yourself for Apple's revolutionary new generation input device...

    Scroll down for the video.
  • Reply 3 of 19
    SpamSandwichSpamSandwich Posts: 26,173member
    Quote:
    Originally Posted by keith_harper View Post


    This is driving me nuts…*the new Magic Mouse is so touchy that while I am working in Photoshop or Illustrator, it is constantly shifting the page around.



    Imagine you were using the Hand tool, and it was moving left, right, up down at random…



    I have been looking for a way to disable this, but can't find anything application specific.



    Help!



    This has never been satisfactorily answered.



    The application called "BetterTouchTool" is lousy and only works occasionally... "MagicPrefs" application is only so-so... AppleScripting an event to turn off the scroll wheel is a bust... Who can point me (and Keith) in the right direction?
  • Reply 4 of 19
    molowamolowa Posts: 2member
    Hello,



    We got a request for such a software. We found a way to do it and are right now packaging it as an app that will be in the Mac App Store. It is using the same mechanism as Palua, our other app.



    Basically, you get a global shortcut that does the switch, and you also get a smart mode that activates or deactivates the scrolling (vertical and/or horizontal customizable) based on the application that has the focus.



    How does that sound?



    Check Palua on the MAS or on our website to have an idea of the features.
  • Reply 5 of 19
    Guys,



    As some of you have heard, by getting in touch directly, this tool won't be released. We do have a valid binary working fine, and disabling horizontal scrolling, but it only works in 10.6. With Lion, gestures became so intimately tied to the system that it just can't be allowed to disable this horizontal scrolling.



    As a consequence, it is possible to completely disable scrolling on the magic mouse, both horizontal and vertical, but not just horizontal However, no scrolling kinda kills the magic in the magic mouse.



    The other product, Pa'ina, is a tool to deactivate the TAP-TO-CLICK feature of the trackpad, it has nothing to do with the scrolling. The scrolling killer tool is called Lolelole, but again, it will not be released on the MAS. If you are using 10.6, and want this feature, get in touch with us through the website (www.molowa.com) and we'll see jhow we can provide you with a binary.



    Olivier./.
  • Reply 6 of 19
    boonyboony Posts: 1member


    Not sure whether the trail has gone cold on this one but I just wanted to vent my frustrations with this feature. To have the mouse control the scrolling down and across the pages is fine but as it is also 'dialling' up and down the object size in the Object Pallette in Illustrator is simply daft in my opinion!


     


    Why on earth would I want to adjust the object size by scrolling the mouse until I hopefully rest on the right dimension???  If I want it to be 10mm tall then I will type 10 and hit enter. 


     


    AAARRRRGGGHHHH


     


    Sorry to all for the rant (except those at Apple or Adobe responsible for this) 

  • Reply 7 of 19


    if this is still actual maybe trying http://magicprefs.com/ works fine and can be easily configured

  • Reply 8 of 19


    Originally Posted by saffron View Post

    if this is still actual maybe trying http://magicprefs.com/ works fine and can be easily configured


     


    I've never had any trouble with either my Magic Mouse nor my Magic Trackpad in either of them. I guess it's fixed.

  • Reply 9 of 19
    quidenquiden Posts: 1member

    I was having a problem with this in Illustrator as well and found the answer.

     

    The problem is that when I'm using my magic mouse, if I just accidentally brush my finger across my Magic mouse, then it would send my document into a random scroll that would slowly slow down until it stops. I would loose my ability to do anything until it stops and it was getting annoying.

     

    To fix this, the control isn't actually in your mouse preferences, but instead it is in the Accessibility preference pane in System Preferences. 

     

    Once you are in Accessibility scroll down to "Mouse and Trackpad." Click on the "Mouse Options" button and in the checked scrolling pop-up, select "without inertia." Leave scrolling checked.

     

    That fixed the problem for me. Hope it helps.

     

  • Reply 10 of 19

    YES! This totally fixed the problem for me! The rampant scrolling problem in Photoshop and Illustrator has been driving me nuts for years, I tried the 3rd party mouse tools and they just get outdated and stop working.  I just never thought to look in the Accessibility panel but suspected maybe that was it. Now I can stop yelling at my screen every time I just accidentally even breathe on the mouse.

     

    YEAH!

  • Reply 11 of 19

    Thank you quiden, I have been trying to resolve this for months and your solution finally nailed it!

  • Reply 12 of 19

    Yes, kudo's to the original poster and special thanx to quiden for that little gem. I could not  settle on disabling the middle single finger scroll effect. Turning off the inertia has lessened the problem 95% so I"m tickled pink. I too have been pestered by this for years, thanx people

  • Reply 13 of 19
    rwramrwram Posts: 1member

    I just upgraded to 10.10.2 from 10.6.8 and I have alleviated many of the moving pains. Fixing broken applescripts and replacing broken applications, stuff like that. Then I hit this brick wall. Turning off inertia helped some but the graphics programs still jump all over the place.

    I still have 10.6 on a partition but I was hoping not to have to go back and forth.

    It's not like gestures are so bleepin' important on macs like they are on iphones or ipads

    So... now I just wear a glove, and until apple fixes this silly problem I can only think of one appropriate gesture... with one sweaty finger.

  • Reply 14 of 19

    If you are here in this forum because of the persistent problem with the ineffectiveness of the Magic Mouse preference settings in OSX as regards scrolling, here is what you need to know:



    About The Problem:

    Apple is not going to fix this problem. It's been an issue dating back several years and continues still. It is either beyond the scope of Apple's programming intelligence, or they simply don't care about you and your problems. Apple's programming intelligence pretty much speaks for itself, so the only option left is that Apple doesn't care. It's one of the perks of the modern day tech business paradigm, where companies like Apple have so many millions of customers and so much momentum behind their market share, they don't have to care about you, the single, obscure nobody, with your Apple computer you've already paid for. Apple also being a die-hard fan-based enterprise, it knows full well that for every one of us who might have a problem such as this, there are at least a hundred thousand others who would put up with just about anything just to be associated with the logo of an apple with a bite taken out.



    The Fix:

    Fortunately there is a brilliant, enterprising soul (or group of souls) behind the development of an app called MagicPrefs which more than compensates for Apple's indifference to this & other related problems. It not only addresses the inability to turn off the ever-annoying scroll action that happens anytime our fingers brush across the case of the mouse, it offers myriad other functions you might like.



    You owe it to yourself to check out MagicPrefs, and thank the developers for giving us a means to rise above this bit of Apple stupidity.



    Cayce

  • Reply 15 of 19

    MagicPrefs is brilliant.  I can restrict the scrolling zone to the location where the scroll wheel is on other mice.  I am no longer accidentally scrolling while I click.

  • Reply 16 of 19
    SpamSandwichSpamSandwich Posts: 26,173member
    fermion wrote: »
    MagicPrefs is brilliant.  I can restrict the scrolling zone to the location where the scroll wheel is on other mice.  I am no longer accidentally scrolling while I click.

    MagicPrefs helped a bit, but I eventually got rid of it because it was so inconvenient to switch on and off only when needed. For the most problematic situations, I just use a Wacom tablet instead of the mouse.

    It is odd that Apple seems to have never acknowledged the problem with any kind of a software fix or mouse settings option.
  • Reply 17 of 19
    Quote:
    Originally Posted by quiden View Post

     

    I was having a problem with this in Illustrator as well and found the answer.

     


     

    I just registered on this board purely to say THANK YOU. That was driving me nuts!

  • Reply 18 of 19

    You sir are a bona fide genius. 

    This was driving me absolutely crazy in Illustrator with the same issue.

    Many many thanks.

  • Reply 19 of 19
    tnian said:

    I was having a problem with this in Illustrator as well and found the answer.

    Not to be negative or anything but:
    What was the answer? I´m still in the dark, and it´s 2017.

    The latest Photoshop release has a couple of options that makes the constant scrolling a bit less of a headache.  Check out the options for "Flick panning" and "Overscroll" in Preferences. There is, however, no such thing in Illustrator as far as I know.


Sign In or Register to comment.