simplified chinese font problem

Posted:
in Genius Bar edited January 2014
Hi,



I received a Word document from a friend that contains a mix of English and simplified chinese but the chinese characters just come up as stange symbols (not characters)...can anyone help me please.



Thanks in advance.

Comments

  • Reply 1 of 3
    Will you post a screen shot for that here? or provide a link for me to download that WORD doc? I am running a Chinese translation team here and i may be of help [Free for your small piece, of course]
    edited February 23
  • Reply 2 of 3
    proxy said:
    I received a Word document from a friend that contains a mix of English and simplified chinese but the chinese characters just come up as stange symbols (not characters)...can anyone help me please. 
    I'll assume you've tried selecting all (including the English) and setting the font to a Chinese font. In the olden days, Word used font information to determine text encoding, so it's possible a simple font change could magically fix it.

    If that doesn't work, then it sounds like an encoding issue. It used to be a constant headache, but in recent years (due to the widespread adoption of Unicode) not so much.

    Most likely, the document is encoded for Simplified Chinese (i.e., GB2312 or GB18030), but Word is treating it as Unicode by default. So you have to tell Word it is a GB 2312 document. The only way I can think to do that in Word 2016 is use the Save As... dialog to save (a copy of) the document in the plain text (txt) file format. In the file conversion dialog you can reset the encoding by choosing "Other encoding" and selecting Simplified Chinese.

    If that doersn't work, try copying and pasting the text into a quality text editor designed for this kind of thing, like Jedit X Plus, or something like BBEdit/TextWrangler.
  • Reply 3 of 3
    Ha! Thanks to the now-banned malevolent user, I see I posted a reply to a post from 2003 -- only 14 years late! Of course, that was exactly when these sorts of encoding issues were at their peak.
Sign In or Register to comment.