Boot and permissions problem

in Genius Bar edited January 2014

I have a G4 1.25 mirrored door tower running 10.4.11. I recently tried to optimize the HD using Tech Tool Pro 4.6.1. during the optimization process TTP hung and I had to force quit.

I have since run diskWarrior and TTP again repaired the problems that weere found and all volume directories and files are fine in both apps on the main HD. However, the HD is no longer seen as bootable except in the startup disk dialog window. it will not boot from that HD. I have a second internal HD from which I boot now.

I have tried restarting and holding down the option key to choose between the two HDs but only the secondary HD shows in that start up window. Both HD systems (10.4.11) show up in the change startup disk dialog window but it always boots from the secondary HD. Both DW and TTP show the mian HD as being fine with no volume directory or file problems.

Since running the Diskwarrior and TTP programs fixing both drives, I have tried to repair permissions on the main HD and always get the error that "disk utility has lost the connection to the disk tool manager" and have to force quit disk utility. Disk utility works fine on the secondary HD. I have tried Cocktail to no avail. cocktail hangs also.

Do I have to Archive and reinstall? Is there any other option that is open to me?
Sign In or Register to comment.