Color scheme

Posted:
in Feedback edited January 2014
As I get older, my eye sight gets older, too. Go figure. The color scheme of AI is causing me trouble.



The postings and such look good on the gray background, but form over function doesn't work for me in this case.



Wording on a gray background is becoming increasingly difficult for me to read. Is there a way to change that scheme? I'd be far more able to read Black wording on a White background like this dialog box.

Comments

  • MarvinMarvin Posts: 13,541member, moderator
    You can change the site stylesheet with the browser. If you open the Safari web inspector, you can use the cog on the right hand side to add a stylesheet rule. If you add one and type:



    .alt1{

    background-color:#FFF;

    }



    this will change all post backgrounds to white but only for the current page - it resets for every page. For a permanent change, create a plain-text textedit document and add the above code into it, saving it as appleinsider.css. Then in Safari, use preferences > advanced > stylesheet and choose the appleinsider.css file.
  • sequitursequitur Posts: 1,869member
    Something is not working.

    I copied:



    .alt1{

    background-color:#FFF;

    }



    into Text Edit and tried to save it as appleinsider.css



    I got an error message:

    You cannot save this document with extension ".css" at the end of the name. The required extension is ".rtf". You can choose to use both, so that your file name ends in “.css.rtf”.



    When I try to select it with both extensions with Safari > Preferences > Advanced > Stylesheet, it is grayed out. I tried it with just .rtf, and it is still grayed out. I tried deleting the .rtf, leaving just .css. It is then recognized as a cascading style sheet, but doesn't change the background color on appleinsider.



    What should I try next?
  • MarvinMarvin Posts: 13,541member, moderator
    Quote:
    Originally Posted by sequitur View Post


    I got an error message:

    You cannot save this document with extension ".css" at the end of the name. The required extension is ".rtf". You can choose to use both, so that your file name ends in ?.css.rtf?.



    In Textedit, you need to use the menu Format > Make Plain Text before saving. It may add a .txt extension but you just remove it in the Finder.
  • sequitursequitur Posts: 1,869member
    Quote:
    Originally Posted by Marvin View Post


    In Textedit, you need to use the menu Format > Make Plain Text before saving. It may add a .txt extension but you just remove it in the Finder.



    Making the Text Edit Plain Text and removing .txt grays it out when trying to select it. Changing it to .css manually shows as a stylesheet when selected; however it still doesn't change the background.



    What am I doing wrong? What else can I try?
  • MarvinMarvin Posts: 13,541member, moderator
    Quote:
    Originally Posted by sequitur View Post


    Making the Text Edit Plain Text and removing .txt grays it out when trying to select it. Changing it to .css manually shows as a stylesheet when selected; however it still doesn't change the background.



    What am I doing wrong? What else can I try?



    It seems to not be overriding certain things. If you change the text in the file to the following:



    td{

    background-color:#FFF !important;

    font-size: 15px !important;

    font-weight:bold !important;

    }



    save the file, then turn off the stylesheet and on again, that should make the text easier to read.
  • sequitursequitur Posts: 1,869member
    Quote:
    Originally Posted by Marvin View Post


    It seems to not be overriding certain things. If you change the text in the file to the following:



    td{

    background-color:#FFF !important;

    font-size: 15px !important;

    font-weight:bold !important;

    }



    save the file, then turn off the stylesheet and on again, that should make the text easier to read.



    Perfect! Even better with the larger font. You always come through, Marvin. You da man.



    Thanks much.
  • sequitursequitur Posts: 1,869member
    Marvin,



    That has solved a lot of my problem in other areas besides AI; however, it may have a negative factor. Incoming .jpg's to Macmail are blurry and when I try to forward them from Macmail, the pix are blurry and too tiny to see. It may not be a result of the new .css, but I haven't experienced it before.



    Is there a work around to prevent that? Don't be concerned it you don't have an answer. It's a small price to pay for being able to read everything else.



    Edit: I find that it doesn't happen in all cases, and oddly, in Mail, typed words aren't always enlarged as in other apps. Apparently, macMail doesn't play nice with the new .css/
  • MarvinMarvin Posts: 13,541member, moderator
    Quote:
    Originally Posted by sequitur View Post


    Incoming .jpg's to Macmail are blurry and when I try to forward them from Macmail, the pix are blurry and too tiny to see. It may not be a result of the new .css, but I haven't experienced it before.



    Edit: I find that it doesn't happen in all cases, and oddly, in Mail, typed words aren't always enlarged as in other apps. Apparently, macMail doesn't play nice with the new .css/



    The .css file should only be affecting Safari. The Mail issues will be caused by something else. The font-sizes for Mail messages are in the Mail preferences. The blurry images are possibly just a one-off.
  • sequitursequitur Posts: 1,869member
    Quote:
    Originally Posted by Marvin View Post


    The .css file should only be affecting Safari. The Mail issues will be caused by something else. The font-sizes for Mail messages are in the Mail preferences. The blurry images are possibly just a one-off.



    I've found that to be true. The problem I had seemed to be an anomaly and not from the new .css

    It was just a coincidence that it occurred at the same time I started using your .css



    Your suggestion has made my life so much easier, now that I can read the screens without having to struggle to decipher them.



    Thanks again
Sign In or Register to comment.