Hi all. First post, and sorry to say my first post is a question. I'm not computer illiterate by any means, but when it comes to Mac--well, my Mac glory days were 7.5.3, and I never cought up with the newer systems. I'm working on a G4 that had OS 9.2.2 on it. Friend asked if I could upgrade it to 10.5. After some reading, I said "Sure, no problem". Proceeded. Figured I'd install an older version of OS10 first and then upgrade that to OS10.5, since the OS10.5...