I have been trying to downgrade from 1.2 back to 1.1.4...always erro message (20) and I am looking for unlock for 2.0