or Connect
AppleInsider › Forums › Software › Mac Software › Safari browser font now super bold
New Posts  All Forums:Forum Nav:

Safari browser font now super bold

post #1 of 11
Thread Starter 
Since I installed Snow Leopard the bold font in Safari is now a rather ugly extra bold font. The rest of the type is still ok.
post #2 of 11
Yep, this is by design unfortunately.

Here's how to revert it

In Snow Leopard, you can only choose between Automatic and Standard CRT. Since few people use CRTs these days, most users now have only one option: Automatic. The problem with the Automatic option is that OS X incorrectly detects many third party LCD monitors as CRTs, and consequently, disables LCD font smoothing.

You can force OS X to use LCD font smoothing on all displays with this Terminal command:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 2
The number 2 here corresponds to Medium - Best for Flat Panel. You may also use 1 for light smoothing, and 3 for strong smoothing, as per the original OS X font smoothing options.
post #3 of 11
Yet another 'flaw' in Snow Leopard! To add to the list of, at least, dozens, and perhaps even hundreds of other 'flaws', shortcomings, and glitches causing headaches, aggravation, and considerable productivity loss for thousands of loyal users ...

Snow Leopard was clearly not yet ready for release! Shame on Apple!
post #4 of 11
Thread Starter 
thanks for the tip but that hasn't helped. It appears the actual font is different - extra bold or black.
post #5 of 11
Post a screenshot please.
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
post #6 of 11
Thread Starter 
post #7 of 11
I am definitely not seeing that on my SL Macs.
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
post #8 of 11
just go into safari preferences and choose a smaller font
post #9 of 11
Quote:
Originally Posted by bbwi View Post

just go into safari preferences and choose a smaller font

That's not the issue. Looks like a bug to me. Try repair permissions and restart your Mac.
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
post #10 of 11
Quote:
Originally Posted by Ireland View Post

That's not the issue. Looks like a bug to me. Try repair permissions and restart your Mac.

How does this at all resemble a permissions problem?

If you're using a Macbook then maybe you zoomed in by accident. Are you using a Macbook?
post #11 of 11
Quote:
Originally Posted by bbwi View Post

How does this at all resemble a permissions problem?

If you're using a Macbook then maybe you zoomed in by accident. Are you using a Macbook?

Believe it or not this sometimes helps with this sort of issue. Resemble? It's not about resembling, it's about going through the motions. It's certainly not zoomed in, that's for damn sure. You can argue all day, but trail and error can't be argued with.
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
Citing unnamed sources with limited but direct knowledge of a rumoured device - Comedy Insider (Feb 2014)
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mac Software
AppleInsider › Forums › Software › Mac Software › Safari browser font now super bold