post #1 of 1
Thread Starter 
Hello All,

I´m a newbie so sorry for all the background but I´m not sure what has caused the problem. To begin with... I upgraded my OS system to Snow Leopard and had some permission problems with iphoto. I searched forums for a solution and was told to use something called Library Permissions which I downloaded and ran. That sorted my problems with iphoto and importing photos from my iphone and desktop but then I saw that my external Lacie hardrive was locked. The permissions had all changed to "custom" and my access was denied. I couldn´t eject it either (it said the external hard drive was in use) so I restarted my computer to eject it. Now the computer just restarts, shows the apple icon with the little time circle running and then restarts again and does it all over, and over. I restarted holding down command and S . The black screen fills with text and I don´t know if this is important but...towards the end of the text it says "Root device is mounted read-only"?
I typed in /sbin/fsck -fy and the screen ran
**Checking Journaled HFS Plus volume
**Checking Extents Overflow file
**Checking Caralog file
**Checking multi-linked files
**Checking Catalog hierarchy
**Checking Extended Atrributes files
**Checking volume bitmap
**Checking volume information
**The volume Macintosh HD appears to be OK

I typed exit and the computer re-booted back to the same problem where it just goes into startup mode with the apple icon in the gray screen, over and over....

Any help would be most gratefully accepted.

PS I am currently going step by step through the advice given by Randy Singer "Unfortunately, there are bunch of things that can cause this problem, but Apple's tech note covers most of them in a methodical way." http://support.apple.com/kb/TS2570....