or Connect
AppleInsider › Forums › Software › Mac OS X › Cannot open any X86 program
New Posts  All Forums:Forum Nav:

Cannot open any X86 program

post #1 of 4
Thread Starter 
Here is the error message whenever I open up a X86 program.

What I did was I've installed Xcode 3 and CUPS 1.4.5, after the restart, it started to appear this message. I don't have Time Machine. And also I've tried to uninstall Xcode but still doesn't work. Can someone tell me what's going on and what can I do to fix the system besides reinstall the whole thing? Thanks -- Aaron


Process: Microsoft Messenger [1571]
Path: /Applications/Microsoft Messenger.app/Contents/MacOS/Microsoft Messenger
Identifier: com.microsoft.Messenger
Version: ??? (???)
Build Info: Unknown-100825~0
Code Type: X86 (Native)
Parent Process: launchd [171]

Date/Time: 2010-11-25 10:27:08.067 +0800
OS Version: Mac OS X 10.6.5 (10H574)
Report Version: 6

Interval Since Last Report: 20182 sec
Crashes Since Last Report: 8186
Per-App Crashes Since Last Report: 2
Anonymous UUID: 9A3FC098-C8A4-465F-95B3-EF851F3D01F0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /usr/lib/libcups.2.dylib
Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
Reason: no suitable image found. Did find:
\t/usr/lib/libcups.2.dylib: mach-o, but wrong architecture
\t/usr/lib/libcups.2.dylib: mach-o, but wrong architecture

Binary Images:
0x8fe00000 - 0x8fe4162b dyld 132.1 (???) <321A99FE-F169-91AE-66FF-B4CD007B3E9A> /usr/lib/dyld

Model: MacPro5,1, BootROM MP51.007F.B03, 4 processors, Quad-Core Intel Xeon, 2.8 GHz, 12 GB, SMC 1.39f11
Graphics: ATI Radeon HD 5770, ATI Radeon HD 5770, PCIe, 1024 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (5.10.131.36.1)
Bluetooth: Version 2.3.8f7, 2 service, 19 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en2
Network Service: Ethernet 2, Ethernet, en1
PCI Card: ATI Radeon HD 5770, Display, Slot-1
Serial ATA Device: HL-DT-ST DVD-RW GH41N, 7.93 GB
Serial ATA Device: WDC WD1001FALS-41Y6A0, 931.51 GB
USB Device: USB 2.0 Hub [MTT], 0x1a40 (TERMINUS TECHNOLOGY INC.), 0x0101, 0xfd100000
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x5a100000
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8215, 0x5a110000
USB Device: Hub, 0x0409 (NEC Corporation), 0x005a, 0xfa200000
USB Device: Keyboard Hub, 0x05ac (Apple Inc.), 0x1006, 0xfa220000
USB Device: HASP HL 3.25, 0x0529 (Aladdin Knowledge Systems), 0x0001, 0xfa223000
USB Device: USB UltraPro, 0x04b9, 0x0300, 0xfa221000
USB Device: Apple Keyboard, 0x05ac (Apple Inc.), 0x0220, 0xfa222000
USB Device: USB 2.0 Hub, 0x1a40 (TERMINUS TECHNOLOGY INC.), 0x0101, 0xfa210000
USB Device: HP Designjet Z3200 44in Photo, 0x03f0 (Hewlett Packard), 0x0d14, 0xfa214000
USB Device: EIZO USB HID Monitor, 0x056d, 0x0002, 0xfa230000
FireWire Device: built-in_hub, Up to 800 Mb/sec
FireWire Device: My Book, WD, Up to 800 Mb/sec
FireWire Device: Oxford ATA Device 00, Other World Computing, Up to 800 Mb/sec
post #2 of 4
Reinstall the OS. You are missing framework stuff.
post #3 of 4
Quote:
Originally Posted by aaronchan View Post

Here is the error message whenever I open up a X86 program.

What I did was I've installed Xcode 3 and CUPS 1.4.5, ...

What in the world are you trying to do? CUPS is an integral part of MacOS X. It is already installed and will be updated as needed as your OS is updated. CUPS 1.4.5 is part of MacOS X 10.6.5. To learn everything about your local installation of CUPS, click this link to take you to your localhost CUPS administrative web page. There is no reason for you to install CUPS.

The current shipping version of Xcode is Xcode 3.2.5. It is available at the Apple Development Center as a free download. A version shipped with your computer--either preinstalled or as an optional install on your System Restore disc. There is no reason for you to install an older version.
post #4 of 4

Here is another option.

 

I had the same problem with my Mac OSX System 10.8.4 after update cups from 1.6.2 to 1.6.3.

I have a MacBookPro with the same system version and copy the libcups.2.dylib file form /usr/lib/ then replace the error file in my other Mac.

 

1. Install cups 1.6.2 again

2. Replace the file libcups.2.dylib in /usr/lib/ directory with this one libcups.2.dylib

 

Note: I added the link if you dont have an other mac in the same version available.

 

This works for me.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mac OS X
AppleInsider › Forums › Software › Mac OS X › Cannot open any X86 program