or Connect
AppleInsider › Forums › General › Genius Bar › Apple Hardware › MacBook Pro won't boot (start (?))
New Posts  All Forums:Forum Nav:

MacBook Pro won't boot (start (?))

post #1 of 7
Thread Starter 
My computer, mac book pro (Not really sure 100% what kinda computer it is), won't get past the Apple-logo and spinning-thing at start up. All of this happened after I deleted (unknown) file without knowing I needed it, so my computer freezed, and when I turned it on it won't get past the "intro"-screen.

I have a Snow Leopard CD, and you can hear it spinning when I put it in my computer and it shows up when I press the Alt (or the other name someone gives it) button, next to the hard disc, but when I pick it, the screen turns black for 2 seconds, then I'm back at the Apple-logo and spinning-thing that lasts forever.

If I press shift when i start the computer it shows a "prohibited sign", a file with a questionmark on it and the apple logo, and if the CDs in at the same time it just shows the prohibited sign, but in the end the screeen turns black again, and goes back to the introscreen.

Last thing might worth mentioning is this:

launchctl: Couldn't stat("/etc/mach_init.d"): no such file or directory
getaddrinfo(): nodename nor servname provided, or not known
getaddrinfo(): nodename nor servname provided, or not known
Launch_msg(): Socket is not connected
Launch_msg(): Socket is not connected
BootCacheControl: Could not create temporary playlist file: No such file or directory
BootCacheControl: could not write playlist

Would love some help Thanks.
post #2 of 7
Fooling around in the System folder with invisible files showing !!
Gotta be careful in there - heh, but you know that now, I guess.

Try zapping the pram - hold Command, option, P +R keys at boot. Hold them down til you hear three bongs/chimes.
Try resetting the SMC - go here to find out the correct way for your machine http://support.apple.com/kb/ht3964

I'd grab a copy of disk warrior http://www.alsoft.com/diskwarrior/index.html and try and boot from that - It should boot from the SL cd tho'.
The other thing I'd try is to boot from a firewire external OS backup if you've got one (or borrow one).
Another thing to try is to use an older Leopard install dvd and try to boot.
If trying to boot from cd/dvd hold the "c" key down before the bong if you've got a fw external OS then hold the option key and select the disc



If you do get an OS running then launch Disc Utility.
Select your HDD (manufacturer ID) in the left panel.
Select First Aid in the Main panel.
(Check S.M.A.R.T Status of HDD at the bottom of right panel. It should say: Verified)
Click Repair Disk on the bottom right.
If DU reports disk does not need repairs quit DU and restart.
If DU reports errors Repair again and again until DU reports disk is repaired.
When you are finished with DU, from the Menu Bar, select Utilities/Startup Manager.
Select your start up disk and click Restart

Try those methods first if they fail try booting in safe mode http://support.apple.com/kb/HT1455 - oh I see you've been trying to do that
If nothing works then post back - you may need further assistance.
cheers

edit: ohh just remembered this one from old OS X days. fsck - which stands for file system check

Boot Into Single User Mode

Start up your Mac and immediately hold down the command key plus the letter ‘s’ key (command + s). Your Mac will start up in a special environment that looks like an old-fashioned command line interface (because that’s exactly what it is).

At the command line prompt, type the following:

/sbin/fsck –fy
Press return or enter after you type the above line. Fsck will start and display status messages about your startup disk. When it finally finishes (this can take a while), you will see one of two messages. The first indicates that no problems were found.

** The volume xxxx appears to be OK.
The second message indicates that problems were encountered and fsck attempted to correct the errors on your hard drive.

***** FILE SYSTEM WAS MODIFIED *****
If you see the second message, you should repeat the fsck command again. Continue to repeat the command until you see the “volume xxx appears to be OK” message.

If you don’t see the volume OK message after five or more attempts, your hard drive has serious problems that it may not be able to recover from.

cheers
post #3 of 7
Thread Starter 
Thank you so much for you answer, really appreciate it, but it still doesn't work :-/

I tried everything, except from the third part, due to lack of CDs :P

When we're talking about the safe-mode, everything was going as intended, ***** FILE SYSTEM WAS MODIFIED ***** didn't appear the second time, but when I wrote "reboot" (you never told me to, but I guess that's right as I googled it, hehe) the computer just restarted and went back to the Apple-logo and spinning-thing that still lasts forever.

Still, thanks a lot.
post #4 of 7
ahh - well, bummer.

You need to either now go the firewire boot method- or try Disk Warrior - or try ProSoft http://www.prosofteng.com/products/data_rescue.php

Have you tried running the Mac Hardware test dvd ? Hold "d" down at boot. See if it can pick something up.
fwiw - I have used Disk Warrior for years for these emergency situations. I have never used ProSoft yet but I have heard that it's very good and saved otherwise hopeless situations.
post #5 of 7
I am just wondering if you ever resolved the problem?
My comuter is acting up in a similar fashion.
post #6 of 7
you need to install an OSX version from the DVD install that came with it. it installs kext that is not in any of the snow leopard install dvd. I suppose apple will come out with an updated 10.6.7 dvd install?

we are now having problems with these new machines not able to netboot in deploystudio
post #7 of 7

I'm a college student 2 days out of finals with a huge essay that I was in the middle of when I had this problem. 2 hours of searching later your method fixed it. Thank you so much!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Apple Hardware
AppleInsider › Forums › General › Genius Bar › Apple Hardware › MacBook Pro won't boot (start (?))