post #1 of 1
Thread Starter 
I have Snow Leopard 10.6.7 on a White IMac.
Since the very day I installed 10.6.4, I have experienced frozen and black screens that require a re-boot.The problems are extensively discussed in these, and Apple support forums, but no solution found. Each successive release has made it worse, and 10.6.7 is much worse.

The only solution i have heard is to go back to a previous release.
However, on trying this I get messages saying Disk is not compatible.
Release notes for instance for 10.6.5 say requires 10.6.4 to upgrade.

Is there a simple way of going back to an earlier release ????, or does it require me to go back to 10.6.1 and add sucessive releases till i get to the latest stable one. 10.6.3 ??.