or Connect
AppleInsider › Forums › General › Genius Bar › NetBoot image problems (Spotlight mostly)
New Posts  All Forums:Forum Nav:

NetBoot image problems (Spotlight mostly)

post #1 of 2
Thread Starter 
Hey Everyone,

We have a summer class at the university I work for that uses a NetBoot image for nearly 30 computers, which gets rebooted every time the class begins. Until this summer, we were using a Mac OS X 10.5 image that served our needs fine and worked correctly. For this summer, we wanted some new software that required Mac OS X 10.6, so I updated the image to Snow Leopard, however, some things have broken along the way.

My current issues are dealing with indexing and Spotlight. When the NetBoot image is booted into, there are 3 drives on the desktop. Our NetBoot image volume, pretend it is named "root_drive_", (the effective root directory referenced either by / or /Volumes/root_drive ), the "Macintosh HD" local machine disk volume (referenced though the folder /private/var/netboot ), and the "BOOTCAMP" local machine disk volume (referenced though /Volumes/BOOTCAMP).

When we searched for files in the root_drive volume using Spotlight, we couldn't find them. I figured out through some research that they were not being indexed because of a ".metedata_never_index" file located at the root of the volume. Every time I tried to delete that file in the image source, it reappeared after taking an image of the source. I was able to delete it permanently by mounting the image after imaging and deleting it. This fixes the problem of those files not being indexed. Sort of.

Now whenever I boot into the NetBoot image, it has to spend a while indexing the root_drive volume before it can find files via Spotlight. I tried indexing before I captured the image, yet it still does this when I boot into it for some reason.

Another problem is that the local "Macintosh HD" volume shows up in the spotlight results as well. I tried resolving this by putting /private in Spotlight privacy, and even putting /private/var/netboot in Spotlight privacy, but despite those being there it still indexes that volume. I can't run "sudo mdutil -i off /private/var/netboot" either because it is not a volume technically (apparently), but just a folder on the root volume. I ran "sudo mdutil -i off /Volumes/BOOTCAMP" as well to prevent indexing on the BOOTCAMP volume, but it is still being indexed.

Any ideas?

Thanks!
post #2 of 2
Thread Starter 
Finally found a fix for this at this location:
https://discussions.apple.com/thread...art=0&tstart=0

By default, Spotlight searching is disabled since this is a network volume and effectively read only, in order to prevent unnecessary network and CPU activity. A workaround for this is to mount the NetBoot image and run:

rm /Volumes/<volume_name>/.metadata_never_index

Now eject and re-mount the NetBoot image to flush the Spotlight cache. Then run:

mdutil -i off /Volumes/<volume_name>
mdimport /Volumes/<volume_name>

This will shut off future indexing of the volume and force build an index of the volume. Now eject the NetBoot image.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › NetBoot image problems (Spotlight mostly)