or Connect
AppleInsider › Forums › General › Genius Bar › Can't start Websharing in 10.1.2
New Posts  All Forums:Forum Nav:

Can't start Websharing in 10.1.2

post #1 of 7
Thread Starter 
I have a server at home (thousands of miles away) that i administer remotely with ssh and VNC. I just upgraded it to 10.1.2, but now i can't get Web Sharing to start (accessing the System Preferences via VNC).

Until now, it was running 10.0.4 with no problems.

The Sharing panel just hangs with 'Web Sharing starting up...' and Apache never starts.

Any ideas?

Thanks,

robo
post #2 of 7
Did you upgrade directly to 10.1.2? Or did you upgrade to 10.1 then to 10.1.2?
post #3 of 7
I am not sure if this is your problem, but when you upgrade to Mac OS 10.1 it breaks the web server. Try starting apache in Terminal.app by typing apachectl start. If it gives you an error about hfs_mod_apple.c or something you need to edit the etc/httpd/httpd.conf file. You only need to change one line from something like AddModule hfs_mod_apple.c(whatever the line that terminal reported an error about) to AddModule mod_hfs_apple.c. Hope this helps.
post #4 of 7
Thread Starter 
I upgraded to 10.1 and then to 10.1.2.

I do get an error when i try to start apache from the command line. I checked the httpd.conf file and it contains the line:

AddModule mod_hfs_apple.c

Which seems to be the correct one...


Any other ideas?


Thanks,

robo
post #5 of 7
What error do you get when you try to start it from the command line?

[ 12-24-2001: Message edited by: seppak ]</p>
post #6 of 7
The way the module is called was changed.

Your httpd.conf probably looks like this:
[code]LoadModule apple_hfs_module libexec/httpd/mod_hfs_apple.so</pre><hr></blockquote>

When it should look like this:
[code]LoadModule hfs_apple_module libexec/httpd/mod_hfs_apple.so</pre><hr></blockquote>

This problem only shows up for people who had previously installed Apple's HFS+ support module...manually or via the Web Sharing Update.
I can change my sig again!
Reply
I can change my sig again!
Reply
post #7 of 7
Thread Starter 
Thanks Eugene, and everyone else. It's working again.

Happy Christmas!

-robo
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › Can't start Websharing in 10.1.2