or Connect
AppleInsider › Forums › Mac Hardware › Current Mac Hardware › Western Digital MyBook-Won't turn on, light not on
New Posts  All Forums:Forum Nav:

Western Digital MyBook-Won't turn on, light not on

post #1 of 2
Thread Starter 

I have two 1TB My Book Studio Editions that are hooked up to a Mac Pro through two Firewire 800 ports.  The problem I'm experiencing is a couple weeks ago one of them stopped working.  The Mac Pro won't recognize it and the light won't come on.  I could feel the hard drive spinning inside though.  I questioned if it had something to do with the switch and if I needed to turn it on to get the light to work.


I have two of these drives so I went to the 2nd drive and pressed the switch a few seconds and it turned off.  Then I pressed it a few more seconds expecting it to turn on but it won't so now both drives aren't working.

 

What would cause it to spin when plugged in but not have the light come on or have the computer recognize it?  Is there a trick with the switch that is causing me not to be able to turn on the second drive?


I am using these drives as Time Machine drives for two laptops that we have connected through the WiFi network to the Mac Pro. Originally I had two WD 750GB drives.  Both of them became defective during warranty and WD replaced both with these 1TB drives.  Unfortunately these are now out of warranty.  Over time I've found them to be unreliable at times.  Often all I would have to do is either unplug it and plug it in again, unplug the Firewire 800 and plug it in again, etc. and it would work. 

 

On a side note, I know these hard drives and most others have two FW800 ports for daisy chaining.  I've always connected both drives directly via two cables to a couple FW800 ports on my Mac Pro but I know they can be used to daisy chain it so I just use one FW800 port on the Mac Pro.  If I do this in the future, would it cause a decrease in performance or would the drives run just as fast?

Thank you for your help.

post #2 of 2
Quote:
Originally Posted by markw10 View Post

What would cause it to spin when plugged in but not have the light come on or have the computer recognize it?  Is there a trick with the switch that is causing me not to be able to turn on the second drive?

Usually, it's the cable that makes the difference between the drive spinning up and indicating that the dive is active. Check if you have a defective cable or worse, a defective port. If possible, try connecting the drive using a different interface like USB.
Quote:
Originally Posted by markw 10 
On a side note, I know these hard drives and most others have two FW800 ports for daisy chaining.  I've always connected both drives directly via two cables to a couple FW800 ports on my Mac Pro but I know they can be used to daisy chain it so I just use one FW800 port on the Mac Pro.  If I do this in the future, would it cause a decrease in performance or would the drives run just as fast?

You probably wouldn't notice any difference in speed but the second one won't power up without the first being active.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Current Mac Hardware
AppleInsider › Forums › Mac Hardware › Current Mac Hardware › Western Digital MyBook-Won't turn on, light not on