or Connect
AppleInsider › Forums › General › Genius Bar › Apple Hardware › Macbook Pro 2011 doesn't startup - damaged components by heat?
New Posts  All Forums:Forum Nav:

Macbook Pro 2011 doesn't startup - damaged components by heat?

post #1 of 2
Thread Starter 

Hi there

I have a macbook pro (early 2011) that when not plugged in and i press the power button to switch on, i can hear the machine running for about 2-3 sec, and then shuts off again. Sometimes, it won't switch on at all unless plugged in with the power chord. If the power chord is in it boots as as per norm...

 

I also noticed that my Macbook switches off randomly when i move/transport it, and usually then it only turns on properly when plugged in. Does this sound like battery failure or possibly a loose contact somewhere? Perhaps even Logic Board (really hope not)?

 

I doubt its a software issue although I have installed bootcamp and played a few games here and there that might have caused the machine to become quite hot. This might have affected my battery/cpu/logic board or whichever i'm guessing?

Has anybody experienced this before or have any advice on this?

Regards

post #2 of 2
Thread Starter 

Thank you for the reply, ill open up the macbook once I have the proper tools and some time. I'm really hoping that the issue is something minor, haven't had this baby for long and I just can't fork out the cash for a new logic board (i rate worst scenario).

 

I appreciate your input, thank you again. Ill update this post when I know more or hopefully solved the issue.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Apple Hardware
AppleInsider › Forums › General › Genius Bar › Apple Hardware › Macbook Pro 2011 doesn't startup - damaged components by heat?