or Connect
AppleInsider › Forums › Mobile › iPhone › Updated to iOS 7 - suddenly I have 2,923 unread emails and 3G issues!!
New Posts  All Forums:Forum Nav:

Updated to iOS 7 - suddenly I have 2,923 unread emails and 3G issues!!

post #1 of 25
Thread Starter 

Hi guys/girls,

 

Firstly let me say that I'm loving the new iOS 7 - simply stunning!

 

I am having having a few issues though:

 

1) I suddenly have 2.923 unread emails! 

 

I have three email accounts on my iPhone - iCloud, Hotmail and one for my website (halabalu).

 

My iPhone seems to think that my halabalu emails haven't been read but when I go into the Mail app, they have been read! Very strange...

 

2) Earlier this morning my iPhone was shown to be connected to O2's 3G network even though I turned it off in the Settings menu

 

Again this is very strange! The reason I usually turn it off is that it drains battery. I only turn it on when really needed....

 

Anyone else having such issues?

 

Regards,

 

Mo.

post #2 of 25
Thread Starter 

Nevermind - fixed the email issue...

post #3 of 25

I've been trying to solve this problem (on both my iPhone and iPad) since I upgraded to ios 7. Can you tell me how you fixed the problem? Thanks.

post #4 of 25
Thread Starter 

Sure!

 

1) Go to your Mail app

2) Under the Mailboxes section at the top of the screen select the email account that is causing you issues

3) Select the Edit button at the top-right corner of the screen

4) At the bottom-left of the screen select the Mark All button

5) Select the Mark as Read option that appears

 

This will mark the selected emails as read. Because I had over 2,000 unread emails, I had to repeat steps 3-5 about 8 times!!

 

Let me know if this helps - or if you need any further assistance :) 

post #5 of 25

Thanks - that worked! As you said, I had to repeat many, many times since I had close to 4000 e-mails. Even Apple Support was not able to suggest this solution. Thanks again!

post #6 of 25
Thread Starter 

Glad I could help :)

 

Wow - 4000 emails!! :wow:

 

Maybe I should print out this thread and send to Apple to blag myself a job as an Apple Genius.... :lol: 

post #7 of 25

Do it! Nothing to lose, and everything to gain ...Thanks again.

post #8 of 25

My Mother's IPad 3 is showing over a billion unread emails after upgrading to IOS7. She always deletes messages once she has dealt with them. It is a BigPond email account. Any suggestions?

 

 

post #9 of 25
Thread Starter 
Quote:
Originally Posted by mareegar View Post
 

My Mother's IPad 3 is showing over a billion unread emails after upgrading to IOS7. She always deletes messages once she has dealt with them. It is a BigPond email account. Any suggestions?

 

 

 

 

Over a billion emails!!  :wow:

 

To be honest, the only solution I can think of is the steps I've described above. 

 

If I can find another solution then I'll let you know but I'm not too confident...

 

Hopefully someone else may have a quicker solution and will reply here :) 

post #10 of 25

I also had over 2 billion emails suddenly unread. I followed the steps from earlier in this thread and only had to do it once and the indicator that 2 billion were unread went away. Go figure.....

post #11 of 25
My edit button doesn't highlight so I can't use it
post #12 of 25

I have the same problem as well.. Usually Mail tells me I have 3,700+ unread emails, but sometimes it changes to 900 unread, 600 unread, 4 unread?? And then sometimes it says I have no unread messages at all (which is what is should be), and then 30 minutes later it's back to some absurd number. I have tried marking all as unread in the mail edit function as described above multiple times, and it does nothing. I've also marked all my messages as read in my email server itself on my laptop at home, also no luck. No idea how to fix this...

post #13 of 25
Your edit button will be highlighted when you have a message you haven't opened. If you don't have an unread message send yourself one if you have an empty mail box you need at least one to make this work. Then do as MoXon describes. Worked for me after I had 218 sitting in my mail even though I had deleted them all from my in box, sent box and trash box.
post #14 of 25

Well what do you know!!!!   This works!

On my iPad I had 18,449 unread messages in two Pop accounts. All the answers to this problem on Google -- except yours -- said you were out of luck if you had a Pop account, it had to be iMAP (like AOL or other big ones)  or there was no solution. 

But lo and behold, hitting "edit" in the inbox and then mark all/mark as read  , removed the annoying 18,449 number. Now all you have to do is mark new spam read and move it to Junk. 

Thank you!!!!

post #15 of 25
Thread Starter 
Glad I could be of use 1biggrin.gif
post #16 of 25

MoXoM.. awesome advice.. I too had close to 3000 emails but my gmail account only has 98 when I pull it up on my work PC.  It's great I don't see that number there anymore but you would think with this hi-tech phone, there would be an easier way now to get the emails off completely..  Their unread but still in your box just not showing on your mailbox ICON.. . Would love an easy way to junk all the mail...takes a long time to mark each one and Junk.. Thanks for your help..

post #17 of 25

I managed to get all my unread emails in GMAIL to be marked as READ, however, it won't work on my iPhone5 IOS 7.0.6

I followed the exact instructions: EDIT, select first email box, MARK and hold down MARK while deselecting the first email box and then the next and only option I have is MARK ALL.  Then the only choice I'm given is FLAG, MARK AS UNREAD and CANCEL

Aaargh!   I've tried this so many times and no luck.   I have not seen the MARK AS READ.  Any suggestions?

post #18 of 25

If you youtube "How to mark my emails as READ on iPhone"  you will see a very easy demo.

post #19 of 25
1hmm.gif Yes me too! I have almost 4,000 and I can't get to them to delete. Did you find an answer?
post #20 of 25
A new twist ?? I have over 1000 emails in my inbox (according to my email icon) ...even says so at the bottome of my inbox column, ......however....they are invisible. No messages appear in the inbox for me to even attempt to delete...... MamaMia.
post #21 of 25
I have the same problem. Please post if you find solution!
post #22 of 25
Thank you so much for this !! You saved a tiny little bit of my sanity ( the rest has already been lost!!)
post #23 of 25
Once you go to mail app, click the edit button next to "mailboxes" and click the unread button. This will add a tab in which you can view all unread messages. Then, keep refreshing. This worked for me.. I had 2 invisible unread emails that went away after I did this. Hope it works for you @LittleTimmy and @Abstract668
post #24 of 25

  Mine shows over 20,000 emails & your suggestions isn't working.  Every time I do it they just come back.

post #25 of 25

Hi
Every time you update OS it changes your mail settings.
Go to

Settings

Mail,contacts,calendars 
Click on whoever your mail carrier is

Scroll down to advanced . Click on.
click on "Delete from server"
Choose . "When removed from inbox"
save.
Problem solved.
Unfortunately you have to go back and delete all those old emails(
 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: iPhone
AppleInsider › Forums › Mobile › iPhone › Updated to iOS 7 - suddenly I have 2,923 unread emails and 3G issues!!