or Connect
AppleInsider › Forums › General › Genius Bar › Apple Software › Terminal command question.
New Posts  All Forums:Forum Nav:

Terminal command question.

post #1 of 2
Thread Starter 

I'm trying to disable Google Chrome updater.

 

I uninstalled Flash a long time ago from Safari, and I drag the favicon from Safari to Chrome whenever I need to use Flash (as Chrome has Flash built in). Now after about 9 months I've decided this is too inconvenient for me so I simply enabled Develop menu in Safari and added this keyboard shortcut to System Prefs:

 

 

This works like a charm. However, the issue I'm encountering now as I expected to is Chrome checks for updates everyday and inevitably that '152' number changes. So to get around this I'm going to stop Chrome updating itself. As I don't use Chrome that often I'm not too concerned about new security patches. However, the only Terminal sudo command I could find to do this does not seem to work:

 

https://support.google.com/installer/answer/147176

 

Here's the commend that person said to use (on page above if you want to read the doc):

 

$ defaults write com.google.Keystone.Agent checkInterval 0

 

Not working. Halp!

Citing unnamed sources with limited but direct knowledge of the rumoured device - Comedy Insider (Feb 2014)
Reply
Citing unnamed sources with limited but direct knowledge of the rumoured device - Comedy Insider (Feb 2014)
Reply
post #2 of 2
Quote:
Originally Posted by Ireland View Post
 

I'm trying to disable Google Chrome updater.

 

I uninstalled Flash a long time ago from Safari, and I drag the favicon from Safari to Chrome whenever I need to use Flash (as Chrome has Flash built in). Now after about 9 months I've decided this is too inconvenient for me so I simply enabled Develop menu in Safari and added this keyboard shortcut to System Prefs:

 

 

This works like a charm. However, the issue I'm encountering now as I expected to is Chrome checks for updates everyday and inevitably that '152' number changes. So to get around this I'm going to stop Chrome updating itself. As I don't use Chrome that often I'm not too concerned about new security patches. However, the only Terminal sudo command I could find to do this does not seem to work:

 

https://support.google.com/installer/answer/147176

 

Here's the commend that person said to use (on page above if you want to read the doc):

 

$ defaults write com.google.Keystone.Agent checkInterval 0

 

Not working. Halp!

I'd try moving the /Library/Google directory to your desktop, or remove it altogether. Also try removing ~/Library/Google. Also, you might need to change the file permissions of the /Applications/Google Chrome.app folder, since the /Applications directory is writable by users in the admin group without requiring a password, so if like most users you are running as an admin user, the Chrome updater will be able to silently write to the Google Chrome folder. Alternatively, instead of futzing around with file permissions you could move your account to a "standard" user and leave a separate "admin" account for system administration. 


Edited by d4NjvRzf - 3/16/14 at 8:13am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Apple Software
AppleInsider › Forums › General › Genius Bar › Apple Software › Terminal command question.