or Connect
AppleInsider › Forums › Mobile › iPod + iTunes + AppleTV › ISP blocking port 25, cannot send mail
New Posts  All Forums:Forum Nav:

ISP blocking port 25, cannot send mail

post #1 of 5
Thread Starter 
Not sure if this is the right forum for this, but for the past week i haven't been able to send any mail from the desktop mail app - it just hangs at "contacting SMPT server," then times out. (Ti 500mHz, OS X 10.2, latest update).

I found out that my ISP (RCN in Chicago, IL) started blocking port 25 to prevent unauthorized bulk spamming from their servers. Apparantly, now all email must be sent thru their SMPT server.

One of the benefits of .mac is that i don't have to use an RCN email account, which will change when i change ISPs. They said i could upgrade my account to a static IP address, and then I'd be able to send mail from the mac SMTP server, but I don't want to pay more for this upgrade and is seems like having a static IP address would be less secure for me.

Other then sending all my mail thru the .mac web interface (which seems like a lame solution), does anyone know of a way around this?
post #2 of 5
just use their smtp server while retaining the .mac account as the return address. in other words, when setting up the account, retain all settings as they are save for the change of the smtp server.
-It's just a computer. It's not a religion.
Reply
-It's just a computer. It's not a religion.
Reply
post #3 of 5
Thread Starter 
Quote:
Originally posted by shiny
just use their smtp server while retaining the .mac account as the return address. in other words, when setting up the account, retain all settings as they are save for the change of the smtp server.

you mean configure an account in the desktop mail app to to reflect this?

and even though i'd list the return address as my mac.com address, if someone hit the "reply" button, would the rcn adress be listed by default anyway. (Because i know that for yahoo webmail you can change the return address to something different which will be listed in the email as the return address, but if you try to reply to the message, the default address is still the yahoo address - it appears to be up to the sender to manually read the listed return address and cut/paste it into the address field when replying)
post #4 of 5
Thread Starter 
got it to work. just as you said, just put smtp.rcn.com as the mail server, no password, now it works.
post #5 of 5
I ran into the same problem last week, while setting up my girlfriend's email on her new iMac. Sympatico DSL service here in Canada has blocked port 25. Apparently, it is ILLEGAL in Canada to allow people to "relay" emails using their ISP. My cable company (Cogeco) doesn't block this port, and in doing so, are apparently in violation of this law... who knows. So just use the ISP smtp settings for outgoing mail.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: iPod + iTunes + AppleTV
AppleInsider › Forums › Mobile › iPod + iTunes + AppleTV › ISP blocking port 25, cannot send mail