or Connect
AppleInsider › Forums › General › Genius Bar › How do you tell AirPort NOT to connect!
New Posts  All Forums:Forum Nav:

How do you tell AirPort NOT to connect!

post #1 of 36
Thread Starter 
My wife's notebook keeps connecting to every other wireless network in the building EXCEPT ours. Now there's a new one called "default" which to me seems like a ploy to get people to connect to it for who knows what reason.


As far as I can tell there's no way to black list a network.
post #2 of 36
hehe default is just the default name for most wireless networks

apple-->system pref-->network-->configAirport-->By default join "name of network"
125/51041 (top .2449%)-Amie Street - awesome independent DRM-free music
People really have got to stop thinking there is only one operating system, one economic system, one religion, and one...
Reply
125/51041 (top .2449%)-Amie Street - awesome independent DRM-free music
People really have got to stop thinking there is only one operating system, one economic system, one religion, and one...
Reply
post #3 of 36
Thread Starter 
and that doesn't take a wep password.

fscking apple needs to get it's fscking control panels updated
post #4 of 36
edit: Ooops, didn't see the answer was right in front of me.
CARTHAGO DELENDA EST
Reply
CARTHAGO DELENDA EST
Reply
post #5 of 36
Actually, it will take WEP. Prefix it with 0x for a Hex WEP password.

Lousy, non-intuitive UI.

We have the same problem here, with several neighbors with WiFi that SWAMPS ours. The 'default' is someone who hasn't given their base station a name... see if they've given it a password, even. :P (Seriously - for a while, when one neighbor was swamping us, we realized that we could surf on their connection instead... wide open.)

Some things to try:

1) Change the channel of your station.

2) Reposition your station for a stronger signal.

3) Turn on Interference Robustness.

4) Warwalk your neighborhood, find out who the offending parties are, and ask them to please play nice.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #6 of 36
Scott is your access point Apple Base Station or something else?

How did you set up your encryption? 64 or 128 bit?
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
post #7 of 36
Quote:
Originally posted by Paul
hehe default is just the default name for most wireless networks

apple-->system pref-->network-->configAirport-->By default join "name of network"


Hmm, not always....Mine's called 'linksys'
post #8 of 36


Did you at least secure it?

RTFM

What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
post #9 of 36
Thread Starter 
Yes I'm using 128 bit wep. And I RTFMed before I bought the thing. The problem is not the router it's the OS X software. There still should be a way to tell it not to connect to some networks or only connect to one.

There's no white list or black list. Kind of stupid for network security.
post #10 of 36
RTFM was directed to psgamer :-)

Scott, when you go to airport preferences in network prefs, you can direct it to join only specific network. It won't join any other.

This way it will join only yours and not the other guy's.

does that help?
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
post #11 of 36
Quote:
Originally posted by Scott
Yes I'm using 128 bit wep. And I RTFMed before I bought the thing. The problem is not the router it's the OS X software. There still should be a way to tell it not to connect to some networks or only connect to one.

There's no white list or black list. Kind of stupid for network security.

*ahem*



You *can* tell it to connect to *exactly one base station*. See above.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #12 of 36
Thread Starter 
Well coming back to this one. Despite all the rude replies from know it all members none of this address the issue. My wife is still connecting to other networks either by mistake or by software error. I would hope some here would look up the meaning of "default" in the dictionary.


So I'll ask again. Is there a way to tell Airport NOT TO connect to a network. Is there an airport black list or white list?
post #13 of 36
If the airport icon shows up on your menu bar, click on it. You should see an option that says "Turn airport off". That should do it.

If it's not on the menu bar, look at the image provided by kickaha. Make sure you click on the box in that window that says "Show airport status in menu bar."

Of course, this completely shuts it off. I would try Kickaha's solution. Nobody in here looks especially rude to me. :-) Peace.
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
post #14 of 36
Quote:
Originally posted by Scott
So I'll ask again. Is there a way to tell Airport NOT TO connect to a network. Is there an airport black list or white list?

Okay, I'll give you the direct answer: There IS NOT an Aiport "black list" or "white list" to tell it NOT to connect to a network.

Your best bet, however, is to use the "Turn Airport Off" and "Join Specific Network" in conjunction with each other. If her computer is joining the one you DON'T want, turn off Airport. When she is in range of the one you want, turn it back on and the computer will join it *first*.

See, OS X and Airport have been designed to keep you connected one way or another. To tell it to avoid those connections is kind of against its very nature. You can tell it, "if you're going to be connected, try this one first," or "just don't even try to connect to anything."

Hope this helps.
Living life in glorious 4G HD (with a 2GB data cap).
Reply
Living life in glorious 4G HD (with a 2GB data cap).
Reply
post #15 of 36
Thread Starter 
There's got to be a way to trick it into not connecting to these on the unix side of things.
post #16 of 36
Quote:
Originally posted by Scott
and that doesn't take a wep password.

fscking apple needs to get it's fscking control panels updated

yes it can, just make sure its 13 characters.
post #17 of 36
Scott for the love of god.... what kind of access point is that?

gimme make/model and i will walk you through that with every screenshot you'll need.
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
post #18 of 36
Thread Starter 
piwozniak what are you trying to help me with?
post #19 of 36
That was your post:
"My wife's notebook keeps connecting to every other wireless network in the building EXCEPT ours. Now there's a new one called "default" which to me seems like a ploy to get people to connect to it for who knows what reason.


As far as I can tell there's no way to black list a network."



Then you mentioned that it won't accept wap.


So.... i guess you didn't configure it properly, right ?

I have 4 networks at work, plus one at home, and never had any problems with connecting to wrong one. If your wap settings are not correct, then you won't be able to join your own network, so...

*that wasn't one of these rude replies*
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
What contemptible scoundrel has stolen the cork to my lunch? _(W.C. Fields)
Reply
post #20 of 36
Thread Starter 
wep wep not wap

Can you tell me how to get it NOT TO connect to a network? If not you cannot help me.
post #21 of 36
Quote:
Originally posted by Scott
wep wep not wap

Can you tell me how to get it NOT TO connect to a network? If not you cannot help me.

You don't need it NOT to connect to the other networks but to connect it to the network you want, and then it won't connect to others.

You're making it much harder than it is.
JLL

95% percent of the boat is owned by Microsoft, but the 5% Apple controls happens to be the rudder!
Reply
JLL

95% percent of the boat is owned by Microsoft, but the 5% Apple controls happens to be the rudder!
Reply
post #22 of 36
Quote:
Originally posted by JLL
You're making it much harder than it is.

I agree. We've given you all the options, and you still persist in asking the same question over and over. It seems like this is more important to you than the very oxygen you breathe to sustain your life. Let it go. Do what we told you and live with it.
Living life in glorious 4G HD (with a 2GB data cap).
Reply
Living life in glorious 4G HD (with a 2GB data cap).
Reply
post #23 of 36
Okay, Scott. You want the laptop to only connect to your network, no matter what?

1) Create a seperate login for your wife, which does not have Administrator rights.

2) Log into that account, and set up the Airport connection. Make sure you select Join a specific network and set that.

3) Turn off the Show Airport status in menubar option, so there's not even a list of the other ones. Use another product like Konfabulator to check your signal strength.

4) Lock the System Preferences. This way, no one can accidentally change these settings.

From that point on, the notebook should only connect to your network. If the network is not available, it will not connect at all.

[Edited to correct a spelling error and clarify a point.]
post #24 of 36
Good God, I even posted a PICTURE in post #11 in this thread.

Scott, I can only surmise you're being dense on purpose at this point. This information will do *EXACTLY* what you said you wanted, which is to connect to precisely the network you specify, and *only* the network you specify. Criminy.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #25 of 36
Thread Starter 
I WILL TYPE IN ALL CAPS SO YOU CAN READ IT BETTER. MY WIFE THROUGH ACCIDENT OR MISUSE IS STILL GETTING ON TO OTHER PEOPLES' NETWORKS. DESPITE SETING UP A DEFAULT NETWORK TO CONNECT TO, SHE STILL ENDS UP ON ANOTHER NETWORK FROM TIME TO TIME.

ALSO AS A NETWORK SECURITY ISSUE IT SEEMS TO ME THAT SOMEONE MAY WANT TO SET UP A BLACK OR WHITE LIST OF NETWORKS TO NEVER CONNECT TOO OR ONLY CONNECT TO.



Why is that so hard?
post #26 of 36
Sorry bub, but if it's through misuse, then it's simply PEBCAK, and short of replacing your wife, there's nothing to be done.

I don't recall anywhere above that you indicated that you had set it to only connect to one network, and it failing. As far as I could tell, you were still off running in circles trying to figure out how to a) get security working, b) set up a white or black list, c) do something 'in the Unix layer'.

Now, take a deep breath, and calm the heck down.

This is simple.

New location, AirPort only, set up to only join a specific network.

THEN if it fails when your wife selects that location, come back and you might get a better response.

Trying to hold us responsible for not knowing that you'd tried something when you never indicated you had is infantile.

Off to Genius Bar with ye.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #27 of 36
Ive got an idea but its just an idea and I dont know the actual commands to make it work...

couldnt you configure the router/airport/wirless access point to use fixed ip's instead of dhcp then configure the en1 script to use a fixed ip also, so instead of airport looking for networks and accepting a dhcp address it will always have the same ip i think you could use a command like

ifconfig en1 192.168.0.2 broadcast 192.168.0.255 mask 255.255.0.0

route add gw 192.168.0.1

and configure the ip of your wireless access point to 192.168.0.1

or it might be preferable to use a different range as 192.168.0.1 is the default for most home networks.

I dont have a command line in front of me (windows at work) so I really dont know if that would work, just a suggestion.
post #28 of 36
Yeah, it's called setting up a Static IP (Manual) in the TCP/IP pane, and telling AirPort to connect to only the one network in the AirPort pane. It's *exactly* what I do at home, no command line needed.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #29 of 36
Thread Starter 
Where does airport have an option to connect to "only one" network?
post #30 of 36
The 'By default, join: A specific network' should only let it attach to the one you specify. Period. It's not supposed to be a 'try this first, and then try others', if that's what your previous post about looking up the word 'default' in the dictionary was trying to allude to.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #31 of 36
post #32 of 36
EVERYONE:

Stop replying to Scott now. Either he will NEVER get it or he's messing with us. We tried. Nothing is getting anywhere, and if he IS messing with us he doesn't deserve the time of day.

I'm done with this thread.
Living life in glorious 4G HD (with a 2GB data cap).
Reply
Living life in glorious 4G HD (with a 2GB data cap).
Reply
post #33 of 36
Thread Starter 
Kickaha and CosmoNut are the only two that provided useful information.

Everyone else answered a question that I didn't ask. It was like talking to a PeeCee help desk.

Me: How do I do this.

You all: You do that.

Me: That doesn't take wep.

Kickaha: You enter wep using 0X

Me: I still want to do this.

You all: You enter 0x into the control panel to do that.

Me: I don't want to do that I want to do this. It's not the same.

CosmoNut: You can't do this. Only that. There's no way to do this.

Me: There's got to be a way to do this.

You all: You do that. You enter it here.

Me: That's not good enough. I want to do this.

You all: What hardware are you using.

Me: What are you trying help me with? Not this?

You all: Why do you keep asking the same question over and over we told you how to do that.

Me: I don't want to do that I want to do this.

You all: Here's step by step on how to do that.

Me: I don't want to do that I want to do this.

You all: We posted a picture on how to do that. What's you're problem.

Scott feels like he's at work dealing with the PeeCee help desk people from work

Scott: I'VE DONE THAT. IT'S NOT WHAT I'M ASKING. I WANT TO DO THIS NOT THAT. THAT IS THAT AND THIS IS THIS. I WANT TO DO THIS.

You all: Calm down. You do that. That wont keep people from doing the other thing. But that is this.

You all: Try this other thing.

Most of this thread was wasted by answering a question that was not asked.
post #34 of 36
Wow Scott.
you took all that time to type that?

Your user title is spot on.
post #35 of 36
I just used software update to update to the newest version of AirPort and with every network I come to it asks if I want to add it to my trusted network. Is this what you are talking about?

Macaddict16
post #36 of 36
Okay, just to clarify again, even though it's been said:

You cannot set up a blacklist / whitelist for Airport networks.

That being said, I gave the exact way to prevent the wife from 'accidentally' connecting to other networks in my post.

Scott, you're right, it does sound like you're on a PC help line. I used to work tech support for Dell, and you sound like some of the customer's I had.

Cust: "I want to do X, because Y is causing problems."

Me: "Hm. Well, X isn't possible, but here's how we can fix Y..."

Cust: "No! You aren't listening, I want to do X!"

Me: "Sir, the problem is Y, though, right?"

Cust: "Yes, and I want to fix it by doing X."

Me: "As I said sir, X is not possible. However, we can fix Y by..."

Cust: "You're not listening to me!!! I want to talk to your supervisor!"

Me: *sigh*
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › How do you tell AirPort NOT to connect!