or Connect
AppleInsider › Forums › General › Genius Bar › Accessing shared iTunes through router
New Posts  All Forums:Forum Nav:

Accessing shared iTunes through router

post #1 of 26
Thread Starter 
I have a Linksys router and now I can't share music with iTunes. I konw that I need to do port forwarding in the router setup. When I go in there I set it up as:
Start: 3689
End: 3689

I am not sure wether to check TCP or UDP protocol but I have TCP selected, and I have it being sent to 192.168.1.100 which is what my computer is. Anyone have any suggestions, because I still can't get the share to work.

Also, would web sharing be set up the same way?

Thanks in advance.

Brian
post #2 of 26
I think your doing too much here. Someone correct me if I'm wrong, but I don't think port mapping is necessary in order to share an internet connection/files on a network/iTunes shared libraries. Try resetting the router back to factory settings and just plug in and try again. Make sure your iTunes libraries are set up to share and that you have file sharing on in System Preferences/sharing. Don't make things harder than they have to be.

In the future, questions like this should go in Genius Bar.
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
post #3 of 26
Thread Starter 
1. I have sharing turned on.
2. Factory settings don't work because I haven't done that much tinkering with it, so basically it is factory default.
3. Correct me if I am wrong, but you do need port forwarding because all requests are going to the router and it doesn't know where to send the requests too.
post #4 of 26
Quote:
Originally posted by DCmac32
1. I have sharing turned on.
2. Factory settings don't work because I haven't done that much tinkering with it, so basically it is factory default.
3. Correct me if I am wrong, but you do need port forwarding because all requests are going to the router and it doesn't know where to send the requests too.

I have a Netgear wireless router set up at my house that is sharing a cable connection. I have basically factory settings as well, but no port mapping, no crazy IP address stuff, just the router. The request will get where it needs to go, you don't have to spell it out for your router. Port mapping is only if you want to run a computer as a dedicated server, has nothing to do with sharing iTunes libraries.
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
post #5 of 26
Punch a hole through 3689 on the Firewall on your machine(s). Make sure it's open on the router too if you're running iTunes 4.0.0 w/ internet sharing, or have enabled that through one of the various hacks around.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #6 of 26
Lynksis router 3 macs 1 PS2, never did anything to the router and all works well. Since I am running a websever from my QS, I have http requests sent to the QS by port forwarding. This forwarding is for requests made from outside your LAN, in other words the WAN.
But that is not your case, you should just plug in your comps and turn on whatever sharing prefs you want for each computer. So reset that router and give it a go. Oh, and make sure you have the sharing turned on in itunes prefs also.
Good Luck, Randy
post #7 of 26
Thread Starter 
Ok, so I took the router down and plugged my computer straight into the ethernet port and the iTunes sharing popped right up. So I reset the router and ran my computer back through it and I lost sharing again. I don't know why it's doing this. Anyone have any ideas, even if it's not port sharing what I can do? Thanks.

Brian
post #8 of 26
Did you take Kickaha's advice? Firewall would be the next most likely culprit. Open up the right ports. In this case 3689. If you don't know how to do this, PM me or post it here and I'll be happy to walk you through it.

Edit:
Kickaha: I'm surprised at you, letting this slip through your fingers! This should probably be in GB, if not GB, than DH. If I'm wrong, I apologize and will take what's coming to me.
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
post #9 of 26
I don't moderate this forum...
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #10 of 26
Thread Starter 
DMBand0026 sorry about all the hassle, but I appreciate the patience and help. Here's what I have going on right now.

I have the built in firewall ON and I have Personnal Web Sharing, Remote Login, FTP, iChat, and iTunes all On. In iTunes, I have 'Look for shared music' checked as well as 'Share my music'. Any ideas.

Brian
post #11 of 26
PC Free Since 1999

"Don't copy that floppy!"
Reply
PC Free Since 1999

"Don't copy that floppy!"
Reply
post #12 of 26
Thread Starter 
Ok. That's what I have.
post #13 of 26
Boof! Off to the Genius Bar!
post #14 of 26
DCmac32, no prob, sorry I haven't been more of a help.
Next I would try killing the firewall on any and all boxes your trying to share with. I don't know what that's gonna do, but it's worth a shot. Make sure your router doesn't have any built in firewalls or anything like that running on it, if it does, kill it and let OS X do the firewall work.
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
post #15 of 26
Thread Starter 
As of right now, I only have one computer set up to the router. My PowerBook should be in by Friday, that's why I am trying to get this set up before then.

I didn't find any settings for a built-in firewall for the router, but I did find a setting called 'Filtered Internet Port Range'. The options of this are Disable, TCP, UDP, and Both. I can then specify a beginning port and an ending one. I set the option to Both and set the ports from 0 ~ 65535, but it ended up blocking all traffic. Any ideas.

Brian
post #16 of 26
'Filtered' could mean 'filtered *out*', ie, blocked.

In which case 'Disabled' would mean 'don't block'.

*shrug* Dunno. It's not like there's a standard terminology that these folks use. :P
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #17 of 26
I would disable it. Opening all the ports wont really serve a purpose, so just disable it. How many computers do you have in your house now? Are they running wireless or what? You said earlier that you unplugged the computer and plugged it directly into the "ethernet port". Do you have a hardwire system running through your whole house?
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
Come waste your time with me

In a world without doors or walls, there is no need for Gates or Windows
Reply
post #18 of 26
Why don't you disable the firewall on the Mac, and let the router's firewall take care of blocking the yucky stuff? I'm sure that's how the others are doing it, and why iTunes sharing is working. Works fine with my Asante router, for example.
Die Grüne Hölle - Gute Fahrt
Reply
Die Grüne Hölle - Gute Fahrt
Reply
post #19 of 26
It sounds like you're trying to share your music from behind your router to computers outside it. You can't do this because Rendezvous is based on subnets, so simply routing external port 3689 to your internal port 3689 won't work. iTunes on your computer still thinks its IP is 192.168.1.100. Other services such as web hosting and file sharing work fine with this kind of port forwarding, but Rendezvous-based services cannot be used from behind a NAT.
Depending on your circumstances and why your are behind a router (is it just for wireless access?), you may be able to turn off the routing feature, uplink it to the rest of the LAN (formerly the WAN), and get your IP from the same DHCP server that's serving the rest of the computers you want to share with. That way you will be on the same subnet and all will be well.
post #20 of 26
Thread Starter 
I shut off the built in mac firewall, but still nothing.
post #21 of 26
Thread Starter 
Noleli2 is there anyway to do that other than taking down the router. The router is just for wireless access. So if I can keep the wirless connectivity and still be connected to the main subnet I would like to do that. Any advice.

Brian
post #22 of 26
Quote:
Originally posted by DCmac32
Noleli2 is there anyway to do that other than taking down the router. The router is just for wireless access. So if I can keep the wirless connectivity and still be connected to the main subnet I would like to do that. Any advice.

Brian

Brian-

Since you said you have a Linksys, I can give you pretty specific instructions. I don't know what kind of experience you have with these things, so sorry if I'm being a bit too specific. I assume you're pretty good since you know how to do port forwarding.

Log into the router and make the following changes:
1. On the main page, change the LAN IP address to something else to ensure that it does not interfere with the router you are going to be going off of, such as 192.168.1.2. Once you do that and click apply, you will have change the IP in the browser to reflect those changes and get back in.
2. Log back in using the new IP, click on the Advanced tab, and click on Dynamic Routing. Change it from whatever it's on to whatever it's not on. They're named weirdly, but I think it's from Gateway to Router, but it might be the other way around.
3. Replug the cable from the WAN port on the wireless router (which is now just acting as on access point) to the uplink port, which should be the highest-numbered port if it's not specifically labeled.

Assuming I didn't forget any steps, your computer's IP should be issued by the same router that is giving the rest of the machines on the network IP's, and iTunes will work fine.

Good luck.
post #23 of 26
Thread Starter 
Noleli2, simply awesome. Worked like a charm. One problem I have is that I am only allowed to have 'one computer legally' on my network here at school. And with your idea it shows the laptop. But what you showed me will help me out when I go home and have to do it there. So thank you very much everyone for all your patience and help. I really do appreciate it. Thanks again. Peace.

Brian
post #24 of 26
I have a linksys router and have no issues sharing my itunes. One thing that you have to make sure, and i know it may sound dunb. The machine you are trying to get music from over your network absolutely must have itunes open.

In other words the app must be running. I know sounds dumb...but often people tend to forget that it has to be running in order to share. So make sure that you have itunes running on both machines when testing :P
Pac10 is the only conference that counts
Reply
Pac10 is the only conference that counts
Reply
post #25 of 26
Quote:
Originally posted by DCmac32
Noleli2, simply awesome. Worked like a charm. One problem I have is that I am only allowed to have 'one computer legally' on my network here at school. And with your idea it shows the laptop. But what you showed me will help me out when I go home and have to do it there. So thank you very much everyone for all your patience and help. I really do appreciate it. Thanks again. Peace.

Brian

Yeah I have the same problem at school. I don't want to have to pay to register my laptop's ethernet port, my router, and my airport card all to the network. I've been working on legitimate ways around this (that doesn't involve hijacking IP's so the IT folks don't get mad at me). I've had very limited success, and I think next year I'll just register my ethernet port and my airport card (the router can clone the MAC of the ethernet port).
post #26 of 26
Thread Starter 
That's what I do here. The problem is we can only buy one IP address. So even if you want to pay for two, you can't. The way I do it is when I am in the room, I use the router and I cloned my MAC address, and then when I go to the lab I just take my laptop and I cloned my IP address on here. THere is no MAC authentication so it looks just like my desktop. Easy, legitamite work around. Thanks for the all the help.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › Accessing shared iTunes through router