or Connect
AppleInsider › Forums › General › Genius Bar › Help with Terminal and Quicktime
New Posts  All Forums:Forum Nav:

Help with Terminal and Quicktime

post #1 of 11
Thread Starter 
Recently I have gained an interest in CLI interfaces and wanted to learn something about them with Terminal.app, but everytime I launch Terminal it launches Quicktime and then exits. This also happens when I launch a new shell of Terminal. How can I fix this? I have been using X11 to learn about the CLI, but I would like this problem to be resolved. Any help is much appreciated.
post #2 of 11
Well that ain't right.

Have you by any chance accidentally set files of extension .sh to open in QuickTime? Do a Get Info on one and see what it says to have open it.
My brain is hung like a HORSE!
Reply
My brain is hung like a HORSE!
Reply
post #3 of 11
Type open -a textedit ~/.profile in terminal and see what text is in there. That's if you use the default bash shell. If you use tcsh, it's in ~/.cshrc or something.
post #4 of 11
Also, check under Terminal's Preferences menu to make sure that QT Player didn't get put in there as a default command.
--Johnny
Reply
--Johnny
Reply
post #5 of 11
Thread Starter 
Kickaha: I did what you suggested and the defaul app is textedit, so thats cool.
Marvin: When I try to open that file terminal says:
2006-03-25 09:47:12.368 open[280] No such file: ~/.profile
[Process exited - exit code 1]
and I'm pretty sure I'm using bash, because the other file name does not work.
Lundy: I checked and it's not there as a default command.


A friend of min suggested that I delete Quicktime's receipts, but I don't know where to find them.
post #6 of 11
What does this give?

open -a textedit /etc/profile
post #7 of 11
Thread Starter 
OK I did that, now what does it all mean?:
# System-wide .profile for sh(1)

PATH="/bin:/sbin:/usr/bin:/usr/sbin"
export PATH

if [ "${BASH-no}" != "no" ]; then
\t[ -r /etc/bashrc ] && . /etc/bashrc
fi
post #8 of 11
Well, in any case, that's not related to QuickTime either.

What's in /etc/bashrc ? Or in .bashrc?
post #9 of 11
Thread Starter 
Nothing that seems quicktime related
post #10 of 11
Next step: Delete Terminal's preference file.

/Users/youracct/Library/Preferences/com.apple.Terminal.plist

Drag it to the Trash.

Restart Terminal.
--Johnny
Reply
--Johnny
Reply
post #11 of 11
Thread Starter 
Did it, it worked. Thank you so much for your help, it is much appreciated.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › Help with Terminal and Quicktime