or Connect
AppleInsider › Forums › General › Genius Bar › Final Cut Pro is running very slowly
New Posts  All Forums:Forum Nav:

Final Cut Pro is running very slowly

post #1 of 6
Thread Starter 
I need some serious help with this because I'm using a quad G5 and it's only encoding using one processor - the activity monitor is showing a whopping 80% of the machine doing nothing.

It also says that Final Cut Pro is using 17-20 threads so I can't understand why the machine isn't using more than one processor - often just half of one too. With Shake, I managed to get it up to 250% = 2.5 processors using 8 threads but FCP won't budge.

It's getting really frustrating having paid over £3000 for a high end editing suite for it to sit on its ass .
post #2 of 6
sees everything you do is slow! Wireless, Marvin you are a cursed man!

jks!

I don't know. is their some setting. And does your version of Final Cut support
DUAL core processors?
There's A virues on your computer. Press Delete to delete the infected files. The following drives will be erased: c:/
Reply
There's A virues on your computer. Press Delete to delete the infected files. The following drives will be erased: c:/
Reply
post #3 of 6
Thread Starter 
Quote:
Originally posted by charliehorse
sees everything you do is slow! Wireless, Marvin you are a cursed man!

Tell me about it . I was trying to get some video from a PC guy at work using Premiere. The stupid software kept crashing during capture and I had to get stuff from the G5 to the PC but there was no way of connecting. After getting the capture working, I had to get the file from the PC to the G5 but wireless is way too slow for a 20GB file. So I decided to use the powerbook as an intermediate connection because the freaking ethernet cable I had was too short. But the powerbook only had 8GB of space free so I had to try and move the G5 close enough to fit. Then when I eventually got the file onto the G5, I get this crap with FCP. I wasted my whole Friday and the film still isn't finished. But I'm taking a break now so hopefully on Tuesday, karma will kick in and everything will just work out .

Quote:
Originally posted by charliehorse
I don't know. is their some setting. And does your version of Final Cut support
DUAL core processors?

It's the latest FCP 5 so I presume it would. I thought the OS handled that. The app splits into threads which it divides between its processors. I'm wondering if there is maybe some hardware fault. It has 4GB Ram so maybe one of the chips is dodgy. I guess I could run the hardware check. It's just really odd that the CPUs are all free for use and the app hardly uses any of it.

I've only ever seen the oppposite happen on any other machine I've used where an app wants to take all of it .
post #4 of 6
Thread Starter 
OK, I've been trying again today to get things sorted out and things are definitely going much better. FCP doesn't seem to like you mixing different media formats. So, I encoded all my files individually into the same format (which wasn't all that speedy but still much lower than together) and export time went down to about 25 minutes whereas it was 2-3 hours before.

However, it's still not fast enough. The most I'm getting out of Compressor 2 and FCP is about 180%. Nearly half of the machine is still unused. I'm not the only one to have found this either. Most of the people on this site found the same:

http://discussions.apple.com/message...sageID=1702608

If it's true what they are saying that FCP and Compressor are not quad-aware then that's very bad because I certainly wouldn't be using a Quad when a Dual-Core would do the same for nearly half the price. I might try the suggestion of upgrading to 10.4.5 but I don't see how 10.4.4->10.4.5 could make all the apps suddenly quad-aware.

Even ffmpeg is only using 100% for DVD encoding.

Another thing I'm noticing is that there isn't a processor system pref pane. Shouldn't I have one of those to be able to enable/disable CPUs?
post #5 of 6
Quote:
Originally posted by Marvin
I need some serious help with this because I'm using a quad G5 and it's only encoding using one processor - the activity monitor is showing a whopping 80% of the machine doing nothing.

It also says that Final Cut Pro is using 17-20 threads so I can't understand why the machine isn't using more than one processor - often just half of one too. With Shake, I managed to get it up to 250% = 2.5 processors using 8 threads but FCP won't budge.

It's getting really frustrating having paid over £3000 for a high end editing suite for it to sit on its ass .

I suddenly remember some macs have something in the energy saver panel which slows the entire machine down. It isn't even restricted to the laptop lines...

from online help:
"Some computers decrease the processor's speed in order to save energy. To increase the speed, open Energy Saver preferences, click Options, and use the Processor Performance pop-up menu."

Probably not it, but worth checking.
I really do hope the next big thing isn't just a piece of UI garnish
Reply
I really do hope the next big thing isn't just a piece of UI garnish
Reply
post #6 of 6
Thread Starter 
Quote:
Originally posted by Tag Me Back
I suddenly remember some macs have something in the energy saver panel which slows the entire machine down. It isn't even restricted to the laptop lines...

from online help:
"Some computers decrease the processor's speed in order to save energy. To increase the speed, open Energy Saver preferences, click Options, and use the Processor Performance pop-up menu."

Probably not it, but worth checking.

Thanks, that was actually the first thing I tried but no luck. I've now run all the updates for the pro apps and got the latest 10.4.6 update and it does the same thing. When encoding audio files or from Pixlet video, it uses about 10-15% of the whole machine and when doing DVD encoding from DV-PAL, it uses at most half of the machine.

I discovered that the processor pane comes from the developer tools. It's actually just the CHUD package that installs it and it shows all four cores are enabled. It does have an option called Nap mode, which is on but from what I read, it can increase power consumption considerably and I don't think it affects performance enough to consider turning it off.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › Final Cut Pro is running very slowly