or Connect
AppleInsider › Forums › General › Genius Bar › Apple Software › iChat
New Posts  All Forums:Forum Nav:

iChat

post #1 of 13
Thread Starter 
Recently I bought a new router, a Netgear RangeMax, my old router was a Micrsoft one, ever sense i switced to this new Router, on start up i can run iChat fine, but after i close it and reopen it gives me an error saying: Lost connection with AIM.
I'll restart my computer and itll work fine untill i close it and want to reopen it and same error, only happened sense i switched my router.
post #2 of 13
Thread Starter 
Bump..
post #3 of 13
Thread Starter 
Any way i can possibly reinstall iChat?
post #4 of 13
maybe reinstall the os? did you try calling apple?
MBA 13" i7/4GB/256GB

C2D MBP 2.33GHZ/2 Gig/120 Gig/256MB
Reply
MBA 13" i7/4GB/256GB

C2D MBP 2.33GHZ/2 Gig/120 Gig/256MB
Reply
post #5 of 13
Disable the Netgear router firewall.

To do this you'll need to go to the router config page. Check you IP address in system prefs if you don't know the router IP. If your IP is 192.168.2.2 for example, the router will likely be 192.168.2.1. Enter it into a browser like Safari and go to the bit about the firewall and turn it off.
post #6 of 13
Null.
Þ & þ are called "Thorn" & þey represent þe sound you've associated "th" wiþ since þe 13þ or 14þ century. I'm bringing it back.
<(=_=)> (>=_=)> <(=_=<) ^(=_=^) (^=_=)^ ^(=_=)^ +(=_=)+
Reply
Þ & þ are called "Thorn" & þey represent þe sound you've associated "th" wiþ since þe 13þ or 14þ century. I'm bringing it back.
<(=_=)> (>=_=)> <(=_=<) ^(=_=^) (^=_=)^ ^(=_=)^ +(=_=)+
Reply
post #7 of 13
I like to keep the firewalls up and running. To many bad things can get on your network if you disable it. Just open ports 5297 and 5298 to allow iChat.
post #8 of 13
Thread Starter 
I go into my system preferences, find out my router number is: 192.000.1.5 and the router number is at the end .1 (made up numbers), than I go into my router settings, go to port forwarding for the final number it has 192.000.1.___ I would enter in .5 or .1? And the the ports it says starting points: Ending Ports: I would enter in S: 5297 E: 5298?
post #9 of 13
Quote:
Originally Posted by mattc908

I go into my system preferences, find out my router number is: 192.000.1.5 and the router number is at the end .1 (made up numbers), than I go into my router settings, go to port forwarding for the final number it has 192.000.1.___ I would enter in .5 or .1? And the the ports it says starting points: Ending Ports: I would enter in S: 5297 E: 5298?

You would enter your number, which ends in .5. Basically it's forwarding information on that port to your computer. The problem with this setup is that if you have a non-static IP, that number can change meaning you have to change the forwarding again. Plus, you can't forward the same ports to more than one machine on the network.

For port number, you would enter 5297 for start and 5298 for end. If you get the option for both TCP and UDP, you can turn that on too.

Turning off the router firewall is perhaps not something you want to do if there are PCs on the network but Macs are more secure and you can always turn on the software firewall.
post #10 of 13
I just switched to a Netgear router and have the same problem. I have another machine (windows pc running Trillian) that can log into my AIM account just fine. I've also looked at the network traffic and it seems to be getting a deliberate "Close Connection" command from AOL immediately after a login attempt. almost like the password is bad, but it's not.

So I don't think it's a firewall or routing issue since it seems to be specific to iChat. I've heard from another person with a similar problem that even the OS X AIM client works, but iChat does not.
post #11 of 13
Well - that's strange. I just added my Mac as the 'DMZ' machine as a test (never do that with a windows machine...), and of course iChat was fine. Then I disabled the DMZ host and iChat is *still* fine. So it may be the routing after all. We'll see if it breaks over time.

The next step is to disable the SPI firewall. You'll still have an inherent firewall setup, I think the SPI just tries to detect denial-of-service attacks on any ports you may have opened deliberately. Perhaps it's getting a false-positive on that detection - again maybe iChat is acting a little different than other AIM clients.
post #12 of 13
Just an update. It did indeed break over time. I guess the router remembered the static route to the DMZ server. Anyway - I disabled the SPI firewall and it works fine again. Certainly not the best solution, but I never had SPI protection before now, and never had a problem. From what I know about DoS attacks, SPI really doesn't help much anyway.
post #13 of 13
The fix!!!!!!!!

Go to Ichat/preferences

click on accounts, then click on server settings

Then put in 443 as the Port.

Done

don't check connect using proxy.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Apple Software
AppleInsider › Forums › General › Genius Bar › Apple Software › iChat