or Connect
AppleInsider › Forums › Mobile › iPhone › iPhone gmail sent mail problems
New Posts  All Forums:Forum Nav:

iPhone gmail sent mail problems

post #1 of 18
Thread Starter 
Hey all, I couldn't figure this out so I thought I'd see if anyone else noticed these two issues I've encountered using gmail on my iPhone.

1) whenever I send an email from my iPhone I then receive it too, as new, in my inbox. I then have to delete it from my inbox... every time I send an email. (I delete it because there's already a copy in my Sent mailbox and I don't want dups)

2) email I send from my iPhone will show up in the Sent section of my gmail on the web, but Mail on my MacBook Pro won't fetch these messages. So basically I have no record of any emails I send from my iPhone on my Mac.

Thanks in advance to anyone who knows any solutions!
post #2 of 18
Thread Starter 
Pardon my own bump, but I still can't find any answers.
post #3 of 18
I'm having exactly the same problem and I cant figure out how to fix it. Not a huge deal, but slightly frusterating...
post #4 of 18
I have this same problem with my Mac getting Gmail with POP. But it only happens when I send from the gmail web app, e.g., at work. When sending from Mail, it works as expected. This tells me either iPhone's Mail needs to be fixed with an update or that you have POP enabled with your gmail account and Mail doesn't need it. Try turning it off in your gmail account settings via the web.
post #5 of 18
anyone figure this out yet?
post #6 of 18
Thread Starter 
No. I went to the Genius Bar because I was worried my battery life wasn't up to par. While I was there I asked about this. The guy said I should turn off Incoming SSL and Outgoing SSL in my Mail settings on iPhone. This did not do anything except stop all messages from being received or sent - not the desired effect.

Maybe I'll call AppleCare to ask. It's still really annoying though.

(Oh, and I sent my iPhone in because I was only getting about 4 hours of use... as of today the status says "Product Replaced" and the return shipment is pending... super-fast service too. I called Wednesday morning, got the temp phone (no charge) and pre-paid FedEx box on Thursday morning, I sent it back Thursday afternoon, They received, diagnosed and replaced it on Friday, and I'll probably get it back Monday. And by the way, syncing with iTunes is a life saver since it backs everything up every time you sync. All I did is swap my SIM, sync, and everything was there again - and not just my media and contacts, but even my browser history, recent calls, SMS chats, recent maps, etc. - way cool.)
post #7 of 18
Thread Starter 
Hey guys. I believe I've found the answer. I can't take credit - Apple has addressed it here.

It looks like all you need to do is the following:

Settings > Mail > [your gmail account] > Advanced > Turn off "Recent Mode"

I hope this helps.
post #8 of 18
Quote:
Originally Posted by -dF View Post

Hey guys. I believe I've found the answer. I can't take credit - Apple has addressed it here.

It looks like all you need to do is the following:

Settings > Mail > [your gmail account] > Advanced > Turn off "Recent Mode"

I hope this helps.

Note that it changes some other behaviors, as well. Just be forewarned. Should be OK, tho.
post #9 of 18
when I do that I can't receive any more new emails though...argggh
post #10 of 18
HUGE BUMP!

I know this is an OLD POST but here are some known issues that i have ran across.

1) we are not alone with this problem.

2) TURNING OFF RECENT MODE stops you from receiving sent mail from your iphone based gmail in your computer based gmail.

3) DISABLING POP does not fix it. once you disable POP, iphone cannot access your gmail and tells you to enable POP.

4) every post and article i have seen says to turn RECENT MODE OFF to stop receiving computer based gmail sent emails in your iphone based gmails inbox but this does not fix it. apparently everyone is misunderstanding our problem, even Apple doesn't understand it as they say to turn off recent mode....

I purchased my iphone on tuesday 10/30/07 and am still having the same problem, which is: anything email i send from my computer based gmail appears in my iphone based gmail's inbox as a new email.

let's see if this gets any responses!
post #11 of 18
Actually this issue has to do with Gmail using POP instead of IMAP.

POP is sort of dumb email system. Where the mail is sent but its only one way communication. Gmail sends the mail but does not communicate with the iPhone to tell it exactly what type of mail it is nor what folder it should go into. So an email you sent from one ends up the inbox of another.

Gmail is being converted to IMAP. I now have IMAP on my iPhone. Gmail communicates with my phone and Mail on my computer letting them both know the status of mail sent and received and what folders they should go into.
post #12 of 18
Quote:
Originally Posted by TenoBell View Post

Actually this issue has to do with Gmail using POP instead of IMAP.

POP is sort of dumb email system. Where the mail is sent but its only one way communication. Gmail sends the mail but does not communicate with the iPhone to tell it exactly what type of mail it is nor what folder it should go into. So an email you sent from one ends up the inbox of another.

Gmail is being converted to IMAP. I now have IMAP on my iPhone. Gmail communicates with my phone and Mail on my computer letting them both know the status of mail sent and received and what folders they should go into.

Are you saying you can work with IMAP on you Gmail account NOW? Can you tell us How. Would be great if true.

Thanks,
post #13 of 18
Quote:
Originally Posted by physguy View Post

Are you saying you can work with IMAP on you Gmail account NOW? Can you tell us How. Would be great if true.

Thanks,

They are rolling it out gradually. Some people have had it for a few days, a lot of people don't have it yet. Some claim that logging out of their account and then back in has made it show up. I was about to complain about how I hadn't been turned on yet, but I just went to check and now I finally have it. Yay IMAP.

It will be in settings of course.
post #14 of 18
If you're from the UK make sure you have language settings to English (US) - IMAP is only activated on US english GMail accounts.
post #15 of 18
This is great news! Thanks to TenoBell and d.mantic for the heads-up. My iPhone is now IMAP-enabled. The mail folders look very different, but in a good way. -- choices!

I'm off to see if I can achieve the same thing in Apple Mail.
post #16 of 18
Does this also affect when you use yahoo or any other form of email? Or is it just gMail? I don't have the iPhone yet but I will soon and I want to know if this will affect my yahoo and hotmail if I access it on my phone..
post #17 of 18
I found this tutorial to be pretty helpful. Step-by-step instructions on how to enable IMAP for Gmail and set it up for iPhone.
post #18 of 18
Quote:
Originally Posted by Mr. Peterson View Post

I found this tutorial to be pretty helpful. Step-by-step instructions on how to enable IMAP for Gmail and set it up for iPhone.

Thank you so much, Mr. Peterson! This problem had been bugging me for a few days (since I just got my shiny new iPhone), and setting the account up as described in the tutorial makes Gmail on the iPhone as I expected it to!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: iPhone
AppleInsider › Forums › Mobile › iPhone › iPhone gmail sent mail problems