or Connect
AppleInsider › Forums › General › Genius Bar › Leopard: Can't Delete Shared Computers from Finder
New Posts  All Forums:Forum Nav:

Leopard: Can't Delete Shared Computers from Finder

post #1 of 20
Thread Starter 
I've just installed my OS X Leopard upgrade this evening, and everything is really good apart from one thing.

In the finder, on the improved left hand menu, it now shows any shared computers. For some reason, a new one has appeared (i don't think it was there before), called "thomson" - this has absolutely nothing to do with me! I presume it must be a neighbour with a wireless PC server. I can't actually add/delete anything - I can only be a Guest.

Is there any way that I can delete this shared computer from the menu? Considering I don't even know the Thomson's, I don't want it there forever!!!

Please help! Thanks.
post #2 of 20
Can you not drag it out of the window? It should go poof! and disappear.
post #3 of 20
Thread Starter 
Nope, dragging out doesn't work. Nor doesn't the delete or backspace key.

I've temporarily solved it by hiding all the Shared category on the sidebar, because i don't use it at all.

Cheers.
post #4 of 20
Quote:
Originally Posted by Mambo06 View Post

I've just installed my OS X Leopard upgrade this evening, and everything is really good apart from one thing.

In the finder, on the improved left hand menu, it now shows any shared computers. For some reason, a new one has appeared (i don't think it was there before), called "thomson" - this has absolutely nothing to do with me! I presume it must be a neighbour with a wireless PC server. I can't actually add/delete anything - I can only be a Guest.

Is there any way that I can delete this shared computer from the menu? Considering I don't even know the Thomson's, I don't want it there forever!!!

Please help! Thanks.

What kind of network are you on? If it's your own wireless network, the guy's using your bandwidth. You can set preferences in your router to kick him out.
post #5 of 20
Thread Starter 
Yeah, I've got a wireless network. It's WPA protected, so that chances of the guy getting into my network is surely pretty slim....? Are you sure that's the only that a PC would appear on my shared page; is there no way he can broadcast his server wirelessly to any computers nearby?
post #6 of 20
Quote:
Originally Posted by Mambo06 View Post

Yeah, I've got a wireless network. It's WPA protected, so that chances of the guy getting into my network is surely pretty slim....? Are you sure that's the only that a PC would appear on my shared page; is there no way he can broadcast his server wirelessly to any computers nearby?

Usually it would show up as a wireless network that you'd have to manually connect to.

I'm not really sure how Leopard deals with that sort of thing though.
post #7 of 20
Dang, I just posted this SAME question. I just noticed TODAY that there is a PC in my shared area i the finder. I can't delete it either. Its really bugging me.
Reply
Reply
post #8 of 20
Apparently its happening to a lot of people. Not sure if this is something that is supposed to happen or not, but there shouldn't be anybody else on my network.

http://discussions.apple.com/thread....sageID=5678534
Reply
Reply
post #9 of 20
I finally got rid of it. There seems to be a neighbor that was using one of the same named routers as I was. I have both an Apple Airport Extreme 802.11n and Linksys 802.11b connected. The Apple router had a password and I didn't set one up on the Linksys, but I just did and it got rid of whoever was on my internet. So now when I was searching networks within range I came across both of mine and then one that was called "linksys" which is what one of mine WAS called. SO I'm guessing my neighbor accidently connected to mine rather than his. Oh well. Problem solved.
Reply
Reply
post #10 of 20
You should always change your router name and password. Otherwise, anyone can easily steal your bandwidth. Encryption is always a plus.
post #11 of 20
I have the same issue as Mambo06 with a server called Thomson showing up in the Leopard finder.

I don't quite understand how he got rid of it but I have found out that my wireless router, a BT Homehub (UK), is actually a Thomson router underneath and it's more likely Leopard is seeing this and marking it as a server/PC than somebody using my network without permission.
post #12 of 20
Thread Starter 
Hi there mate. It's good to hear that someone else has exactly the same problem - so I now know there's no one called Mr. Thomson trying to get into my Home Hub!

To temporarily "hide" it, I've just unchecked all three network boxes in the Finder preferences, under Sidebar. I can do this because I don't have to do much networking around my home.

Just out of curiousity, I'll continue to look and see whether it can be permanently disabled using BT's router admin.
post #13 of 20
I've got the exact same problem, A "Thomson" in my shared computers

And I'm also using a BT HomeHub

I got a bit worried today when I noticed it, but I guess there's no need to worry as a few other people have the sane problem
post #14 of 20
My laptop shows up in shared, but i changed the laptops name, and now it just wont change its name or go away. Ive disconnceted the laptop, added it manually (the new name wont stay), or anything. The old name just sits under shared there and i cant even access it. boooo
Insert witty message here.

Earth.ini corrupt;God.sys not found;Reboot Universe?>_
Reply
Insert witty message here.

Earth.ini corrupt;God.sys not found;Reboot Universe?>_
Reply
post #15 of 20
also i cant "Add to Sidebar" in finder under File. i select it and nothing happens.
Insert witty message here.

Earth.ini corrupt;God.sys not found;Reboot Universe?>_
Reply
Insert witty message here.

Earth.ini corrupt;God.sys not found;Reboot Universe?>_
Reply
post #16 of 20
My network is locked down, tight...with a firewall and two routers behind the firewall that can only be accessed by hard wire an I can visually see the wires that are connected. There's no wifi penetration. There is no wired connections that are unknown.

Internet - FW - Router - Router ----devices

There are no connected devices that can serve as wireless access points...for example a rouge PC/Mac user who turned on networking and made their machine a wifi access point. It's as secure as a wired network can be.

Yet I have devices showing up under the shared section. These are not moochers. The device names are devices I created a while back. Lets say the device name is SMITH. It's still showing up as SMITH though I have removed SMITH from the network and put JONES in it's place. I can connect to JONES just fine. I cannot connect to SMITH, because it is not there, though it remains showing under the list of shared devices.

I have cleared my cache and the reset the arp cache on the routers and firewall but this name still shows up as shared whenever I am on this network. I've rebooted, and it's still there. I go to another network, it's gone. I come back, it returns. Something is stuck or broadcasting the name.

Removing the shared devices from showing up through the finder preferences is not a fix nor a work around, there are legitimate devices that should show up. It's the ones that will not go away tough they have been gone for months that are frustrating.

I have not tried to remove them through terminal by unmounting.

There is an issue that is beyond network security. I can also replicate it on another Mac. Both are running 10.6.5. These dead device names just will not go away.
post #17 of 20
Quote:
Originally Posted by KramerInd View Post

My network is locked down, tight...with a firewall and two routers behind the firewall that can only be accessed by hard wire an I can visually see the wires that are connected. There's no wifi penetration. There is no wired connections that are unknown.

Internet - FW - Router - Router ----devices

There are no connected devices that can serve as wireless access points...for example a rouge PC/Mac user who turned on networking and made their machine a wifi access point. It's as secure as a wired network can be.

Yet I have devices showing up under the shared section. These are not moochers. The device names are devices I created a while back. Lets say the device name is SMITH. It's still showing up as SMITH though I have removed SMITH from the network and put JONES in it's place. I can connect to JONES just fine. I cannot connect to SMITH, because it is not there, though it remains showing under the list of shared devices.

I have cleared my cache and the reset the arp cache on the routers and firewall but this name still shows up as shared whenever I am on this network. I've rebooted, and it's still there. I go to another network, it's gone. I come back, it returns. Something is stuck or broadcasting the name.

Removing the shared devices from showing up through the finder preferences is not a fix nor a work around, there are legitimate devices that should show up. It's the ones that will not go away tough they have been gone for months that are frustrating.

I have not tried to remove them through terminal by unmounting.

There is an issue that is beyond network security. I can also replicate it on another Mac. Both are running 10.6.5. These dead device names just will not go away.

I spent an hour on the phone with Apple Support. This issue of a dead device is completely unknown to them and they could not figure out how to get rid of it.

In my case, on my iMac (Snow Leopard) I wanted to change the name of my login from (example) "firstlast" to "last". Not knowing then how to do it right, I simply created a new login, moved all the files from "firstlast" to "last" and then deleted "/Users/firstlast". Ever since then I have seen "firstlast_host.local" in Shared.

I bought a new laptop and decided to clone the iMac to the MacBook Pro. Now I have that problem on both computers.

The only way out of this is to reinstall everything from scratch and rebuild from the ground up.
post #18 of 20
Sorry, del please .
post #19 of 20
There is an outside chance you may have set that computer to log in at startup. Go to system preferences and hit Accounts. Unlock your account and if the offending server is there hit the minus button and it will be gone for good.
post #20 of 20

ok i have lion like the last poster and here is how i fixed my sharing problem. i went in system preferences to users. from there i made sure it was unlocked to make changes. i then clicked guest which had on. i then unchecked the bottom box allowing computers to connect to shared folders. then it went away

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Genius Bar
AppleInsider › Forums › General › Genius Bar › Leopard: Can't Delete Shared Computers from Finder