or Connect
AppleInsider › Forums › Software › Mac OS X › Dropping wireless connection
New Posts  All Forums:Forum Nav:

Dropping wireless connection

post #1 of 9
Thread Starter 
After upgrading to Leopard my Mac Book Pro continuously drops the connection to our wireless connection. After many attempts the only method I found to correct the situation is to perform a restart. Before the OS upgrade the wireless connection worked perfectly.

I am connecting through a Linksys router with a Time Warner cable connection.
post #2 of 9
Quote:
Originally Posted by brothurb View Post

After upgrading to Leopard my Mac Book Pro continuously drops the connection to our wireless connection. After many attempts the only method I found to correct the situation is to perform a restart. Before the OS upgrade the wireless connection worked perfectly.

I am connecting through a Linksys router with a Time Warner cable connection.

I had a similar problem. After installing the Leopard upgrade (I did a clean install and then used migration assistant to pull over my old user accounts and settings) my airport worked for a minute or two and then slowed down to the point that it was useless.

I found two possible fixes and did them both at the same time. My system now works fine.

restart your Mac and hold down the shift key to load safe mode.
restart your Mac without holding down shift to boot up normal.

I'm not sure of why this is recommended, but I believe it has something to do with Cache files being deleted or recreated. It's possible some cruft from your Tiger cache is causing network problems.

Creat a new "Location" in your network settings. Delete your old "location"
I guess this is because the old setting may not have transferred correctly in your upgrade or install.

I'm not sure if one or both of these fixed my system, but after 2 days my airport is still working great. I'm using a USRobotics wireless router with my iBook G4.
post #3 of 9
Quote:
Originally Posted by brothurb View Post

After upgrading to Leopard my Mac Book Pro continuously drops the connection to our wireless connection. After many attempts the only method I found to correct the situation is to perform a restart. Before the OS upgrade the wireless connection worked perfectly.

I am connecting through a Linksys router with a Time Warner cable connection.

I am having the same exact problem. I just bought my MacBook Pro last week and OS X was already installed. Did the other persons suggestion work? Not sure if I should take to the Apple store or not. It's very frustrating!!
post #4 of 9
I am having the same issue. Mine seems tied to disconnecting the power adapter then reconnecting it. A task most people with laptops expect to be able to do , I think...
Thx,
BarryTheSprout
2 - Mac Mini ?Ghz 2GB Core Duo

1 - MacBook Pro 15" 2.4GHz 2GB Core 2 Duo
2 - iMac 24" ?Ghz 2GB Core 2 Duo
1 - iPod 60 GB 5th Gen
Reply
Thx,
BarryTheSprout
2 - Mac Mini ?Ghz 2GB Core Duo

1 - MacBook Pro 15" 2.4GHz 2GB Core 2 Duo
2 - iMac 24" ?Ghz 2GB Core 2 Duo
1 - iPod 60 GB 5th Gen
Reply
post #5 of 9
I'm having a similar problem. I have a 2-week-old MacBook Pro that came with Leopard installed. When coming out of sleep mode, it often wouldn't reconnect to the router. Or, rather, it SAID it was connected to the Linksys router, but would transfer no data, or transfer data painfully slowly. Then more recently I've been surfing along with an active connection, and then it would just bog down to a virtal standstill. In all these instances, I would reboot and it would reconnect fine. This is my first Mac, and I'm a bit annoyed with this problem. Reminds me too much of my PC. I haven't called AppleCare yet and wanted to do some searching here for others with the same problem.

I'm going to try the boot-in-safe-mode and then boot-normal as mentioned above, and see how that goes.
post #6 of 9
Thread Starter 
I should aplogize for not checking back in on this post. The workaround that I found was to reset my Linksys 300 router in terms of speed. I changed the router from "N" to "G" (effectively reducing the speed) and the connection has not dropped since the change. Somewhere I read that a software fix would be coming but I am not sure of the fix was from Linksys or Apple. I hope this helps.
post #7 of 9
I FOUND A SOLUTION THAT WORKS!!!! First a little back story.

Got my Mac Blackbook and the wi-fi worked great from my Linksys wrt54g2 router. Moved to Germany and into an apartment and my connection issues started happening. My MB would connect once then loose connection quickly and would only recover connection if i either closed and re-opened my screen, or re-connected to my network... then it would drop again before my next page turn.

After multiple days of research I read about SOOOO many others having this issue and the fact the Apple pretty much refused to acknowledge the issue. It seemed that sometime near the OX 10.4.2 update the airport driver got fubar'd leaving all those with Intel based macs wi-fi connects messed up.

Some of the solutions i read about and tried had to do with changing my WEP connection to WPA. This did not work, but i left it as WPA as my research finds it a more secure connection. I also read about and tried setting my Wireless RTA Threshold in my router to 256 from the *2432 default. This as well did not work, though I have left it at this setting as it seems to be the best value for MAC's connecting over wi-fi. This is not true for PC's though so be careful.

More research, more research, o' my brain hurts and my patience is wearing..... then BINGO!!! I found a thread about connection issues that pertained to MB's not connecting to local-network printers. The poster mentioned that MAC's seem to have a hard time connecting to networks that had more than one wi-fi network present. This is my issue i thought. I have 8 in my available connections now. In my old home I had just mine. So i followed the directions suggested and it has now been 2 weeks of 100% perfect wi-fi connections.

Below is the excerpt from this page, http://www.macintouch.com/readerrepo...topic2005.html (Do a find for Little Snitch). The program the writer talks about is called Little Snitch found here, http://www.obdev.at/products/littlesnitch/index.html. It's a $29 dollar program, but in my mind its well worth it to make my $1500 Blackbook work!

This may not be the Apple Fix we have been waiting for them, but its completely working for me.

Quote:
I have used Little Snitch software for several years, and it occurred to me that I might be able to use it to block any connections with the other network. Using the latest version (v.2), go to Preferences, or Little Snitch Configuration, choose Rules under the Window menu, and click the New button.

In the pop-up window that shows up, click on the gear icon and choose "Choose System Process." A file open box opens, and under the folder "libexec," choose "airportd." "airportd" is the system daemon that controls the Airport card in the MacBook Pro. In the box that comes up, set the main menu to "Allow Connections" and the Server menu to "Local Network."
post #8 of 9
I also live in an area where I think the interference is causing all my MacBook Pro wifi drops. I visited my in-laws over the break where there was only one available wifi network in my AirPort drop down, and I never got disconnected. They are using a LinkSys router, but I'm forced to use the ATT UVerse router. In any case, my other macs and pcs never drop, but my macbook pro drop. I can officially say that I've tried this solution, but it simply does not work for me. Thanks for the suggestion though. I don't think any software can really "block out" a wifi signal.

Best,
Laz

Quote:
Originally Posted by cesarcesar View Post

I FOUND A SOLUTION THAT WORKS!!!! First a little back story.

Got my Mac Blackbook and the wi-fi worked great from my Linksys wrt54g2 router. Moved to Germany and into an apartment and my connection issues started happening. My MB would connect once then loose connection quickly and would only recover connection if i either closed and re-opened my screen, or re-connected to my network... then it would drop again before my next page turn.

After multiple days of research I read about SOOOO many others having this issue and the fact the Apple pretty much refused to acknowledge the issue. It seemed that sometime near the OX 10.4.2 update the airport driver got fubar'd leaving all those with Intel based macs wi-fi connects messed up.

Some of the solutions i read about and tried had to do with changing my WEP connection to WPA. This did not work, but i left it as WPA as my research finds it a more secure connection. I also read about and tried setting my Wireless RTA Threshold in my router to 256 from the *2432 default. This as well did not work, though I have left it at this setting as it seems to be the best value for MAC's connecting over wi-fi. This is not true for PC's though so be careful.

More research, more research, o' my brain hurts and my patience is wearing..... then BINGO!!! I found a thread about connection issues that pertained to MB's not connecting to local-network printers. The poster mentioned that MAC's seem to have a hard time connecting to networks that had more than one wi-fi network present. This is my issue i thought. I have 8 in my available connections now. In my old home I had just mine. So i followed the directions suggested and it has now been 2 weeks of 100% perfect wi-fi connections.

Below is the excerpt from this page, http://www.macintouch.com/readerrepo...topic2005.html (Do a find for Little Snitch). The program the writer talks about is called Little Snitch found here, http://www.obdev.at/products/littlesnitch/index.html. It's a $29 dollar program, but in my mind its well worth it to make my $1500 Blackbook work!

This may not be the Apple Fix we have been waiting for them, but its completely working for me.
post #9 of 9
I'm loving my mac but this problem is killing me trying to figure it out. Going to go back to reading my manual!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mac OS X
AppleInsider › Forums › Software › Mac OS X › Dropping wireless connection