or Connect
AppleInsider › Forums › Software › Mac OS X › Safari Issue - no longer adds ".com" automatically
New Posts  All Forums:Forum Nav:

Safari Issue - no longer adds ".com" automatically

post #1 of 87
Thread Starter 
Hello,

I just recieved Leopard for Christmas and I love it.

However, one issue annoys me to no end:
In Tiger, if I wanted to go to a web address that ends in ".com" all I had to do was type the domain name. No typing "www" at the beginning or ".com" at the end. This was enabled by default.

After performing a clean (erase and install) install of Leopard, it appears that feature is gone. I cannot find it in Preferences.

Can someone help me how to reinstate this useful and time-saving feature?
post #2 of 87
Strange... I also have Safari 3.0.4 and it does add .com automatically.
post #3 of 87
That is really odd. Safari has never required this to be typed in any version.

Try going to your user Library>Preferences>safariplist

Drag the plist to your desktop and quit then restart Safari. See what happens. You can always put the plist on your desktop back in if it doesn't work.

If that doesn't work you can always click Safari in the menubar and then click Reset Safari. I think this option wipes out your passwords at websites you visit (like Appleinsider and you will have to add them when you visit the site again.
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
post #4 of 87
Thread Starter 
Quote:
Originally Posted by kcmac View Post

That is really odd. Safari has never required this to be typed in any version.

Try going to your user Library>Preferences>safariplist

Drag the plist to your desktop and quit then restart Safari. See what happens. You can always put the plist on your desktop back in if it doesn't work.

If that doesn't work you can always click Safari in the menubar and then click Reset Safari. I think this option wipes out your passwords at websites you visit (like Appleinsider and you will have to add them when you visit the site again.

Thank you for the suggestion.

I tried it, but unfortunatley it did not work.

Safari still does not add the ".com" automatically like it used to.

I have reset many times, cleared NVRAM and PRAM and moved the plist and restarted.

Most confusing.
post #5 of 87
Quote:
Originally Posted by 9secondko View Post

Thank you for the suggestion.

I tried it, but unfortunatley it did not work.

Safari still does not add the ".com" automatically like it used to.

I have reset many times, cleared NVRAM and PRAM and moved the plist and restarted.

Most confusing.


If you type in: "www.aol" it doens't add the .com

But if you type in just "aol" it adds the .com

Could this possibly be the issue?
post #6 of 87
Quote:
Originally Posted by 9secondko View Post

...

In Tiger, if I wanted to go to a web address that ends in ".com" all I had to do was type the domain name. ...

Are you sure that this "feature" is missing? I believe that you are mistaking a very useful Safari feature for a really bad idea that Apple did not implement. The useful feature is that Safari uses its database of previously visited sites to auto-complete partial entries. To use icfireball's example, Safari will complete "www.aol.com" when you type "www.aol" if you previously visited AOL's website.

Notice that you lost the "feature" when you upgraded to Leopard. I'm betting dollars to donuts that you did a Clean Install or Archive & Install of Leopard which destroyed your previous Safari history. If this is the case, then your "missing" feature will return for each website that you visit in the future.
post #7 of 87
This should work.

Do you have any hacks installed like any APE utilities or saft or PithHelmet, etc?

Try logging in from another user.
--Johnny
Reply
--Johnny
Reply
post #8 of 87
Mr. Me is right.

I had never gone to AOL since Leopard. When I typed aol, I didn't get a .com after it.

Hit return and it went to the site anyway, like always.

Then the next time I typed aol, I did get the .com. Try it with something like ibm or some other site you haven't gone to.

9 secondko, you never did indicate if hitting return would take you to the site. You just noticed the .com didn't come up and felt the need to type it. Don't fear the return key.
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
post #9 of 87
Thread Starter 
Quote:
Originally Posted by icfireball View Post

If you type in: "www.aol" it doens't add the .com

But if you type in just "aol" it adds the .com

Could this possibly be the issue?

no, that is not the issue. Tahnks, though.

The thing that is so great about Safari was that you never had to type unnecessary stuff like the "www" or ".com"

Now, the ".com" just does not appear automatically anymore.
post #10 of 87
Thread Starter 
Quote:
Originally Posted by lundy View Post

This should work.

Do you have any hacks installed like any APE utilities or saft or PithHelmet, etc?

Try logging in from another user.

No other programs no plugins, nothing.

Tried as other user.

What is up with this?
post #11 of 87
Thread Starter 
Quote:
Originally Posted by kcmac View Post

Mr. Me is right.

I had never gone to AOL since Leopard. When I typed aol, I didn't get a .com after it.

Hit return and it went to the site anyway, like always.

Then the next time I typed aol, I did get the .com. Try it with something like ibm or some other site you haven't gone to.

9 secondko, you never did indicate if hitting return would take you to the site. You just noticed the .com didn't come up and felt the need to type it. Don't fear the return key.

Hitting return give me an error page that the site cannot be found.

I never get tot he domain.

This used to work until I installed Leopard fresh.
post #12 of 87
Quote:
Originally Posted by 9secondko View Post

...

This used to work until I installed Leopard fresh.

You aren't paying attention. Reread the earlier posts in this thread.
post #13 of 87
Thread Starter 
Quote:
Originally Posted by Mr. Me View Post

You aren't paying attention. Reread the earlier posts in this thread.

no
look, I know what I am talking about
I clean instAlled tiger a few times and safari always added the .com suffix by itself.
this I'd not dependent on the history.
trust me.
something is wrong and this is a clean instAll
I appreciate the replys but I'd sounds like no one is listening.

Safari is supposed to do what I am saying without the site being in history
post #14 of 87
Well good luck then.
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
post #15 of 87
Thread Starter 
Quote:
Originally Posted by kcmac View Post

Well good luck then.

thanks for trying.

i don't understand why the face icon is in your post.

i read every thread and even responded to most.

my problem is most perplexing and it seems that no one understands it, but rather guess at what the problem is.

safari used to work a certain way and now it does not. even after i reset safari or reinstalled tiger, it would ALWAYS add .com to the domain i typed in, regarless of browsing history.

i would like to resolve this issue without having to reinstall the os since this is a clean install.

now, in this leopard version it does not. surely there must be an answer somewhere.

just because your answers were not correct is no reason to get offended. I really appreciate the help.

thanks again.
post #16 of 87
post #17 of 87

Nice pickup. I was getting the impression this might have more to do with the ISP than the Mac.
--Johnny
Reply
--Johnny
Reply
post #18 of 87
Thread Starter 

Earthlink is not my ISP.

I can see where that could be an issue, but Safari was working fine with my ISP just an hour before I installed Leopard.

Unfortunately, it doesn't seem to be an ISP issue.
post #19 of 87
The face wasn't mean spirited. If you read your last post as someone else, you might understand...

Do you live by an Apple Store? If so, set up an appointment with a Genius and let them look at it. Then someone can actually see visually what you are up against.

I really do wish you luck and Happy New Year.
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
post #20 of 87
Thread Starter 
Quote:
Originally Posted by kcmac View Post

The face wasn't mean spirited. If you read your last post as someone else, you might understand...

Do you live by an Apple Store? If so, set up an appointment with a Genius and let them look at it. Then someone can actually see visually what you are up against.

I really do wish you luck and Happy New Year.

Usually The "rolleyes" icon is to say "whatever.." to someone. that is why I commented on it. You say that it was not intended and I will take you at your word. Thanks for clearing that up. I enjoy this forum and do appreciate the time people like you have taken to comment and try to help.

As for the post you replied to, I have reread it and I am fine with it. Basically, it sounds like someone who is tired of people guessing that it is probably a silly operator error or misunderstanding of how Safari works.

I support PCs and Macs on a network for a living. I know how it is supposed to work. I almost never have to support the Macs (although there are much fewer of them and they are only from the exec users) This one has me totally bewildered. I have scoured the internet and only found a couple of other issues like this.

There HAS to be some explanation. I have installed Windows too many times to count and out of every 500, there will be one where Windows did not install properly and a need for an OS repair or complete reinstall is necessary. Never had an issue with a Mac. If it continues to feel like a pain I may be forced to install the OS from scratch again. I don't want to as it took the better part of a day just to install Leopard, my other apps and configure email.

Thanks for the warm wishes. I hope you have a great 2008 as well!
post #21 of 87
A year or so ago, this same thing also happened to me, but it was my ISP that changed (not earthlink though). I take the same laptop to different places (using safari) and although it doesn't work from my home, it works from other places. (I started a thread about it here - check it out and see if it helps.)

Have you tried this with another computer from your home? I know you said this happened after a new OS install, but I don't think this is really a feature of safari, it's something that happens when safari sends the url out to the ISP. If you can get this functionality back with a different computer, it would lend support to the idea that it has something to do with your OS install rather than the more common-sense explanation that your ISP changed.

Here's a guess: When you installed your new OS, the domain name server entries in System Preferences -> Network -> DNS servers changed. This could change the way your Mac interacts with your ISP, and could account for the autocomplete being off. The fact that you did a clean install is consistent with that idea.
post #22 of 87
fresh/clean install of leopard here. Safari behaves the way mr. me says. As I typed in only "ibm" and hit return it went straight to ibm.com. then as I retried "ibm" it auto filled in teh .com
I guess if it doesn't work on your machine then there may be an issue, but if you are just sitting there waiting for safari to auto-fill something that doesn't seem necessary then I wouldn't know how else to help you.
post #23 of 87
Could you clarify: when you type "IBM" only into the address bar (and erase any autofill that it adds) and then hit Return, what do you get?
--Johnny
Reply
--Johnny
Reply
post #24 of 87
One more thing you could try but since you did a clean install I don't know if it will help or not. Either way, the following is a great utility for OS X and now it is is compatible with Leopard.

http://www.macupdate.com/info.php/id/11582/onyx

Go into the Automation tab and select everything except Repair Permissions. Then hit execute.

Also go into the cleaning tab, click on internet and then select all you want to clean. I don't usually clean cookies or form values.

Restart a couple of times after it is done and then see what you get.
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
iPad2 16 GB Wifi

Who is worse? A TROLL or a person that feeds & quotes a TROLL? You're both idiots.....
Reply
post #25 of 87
Quote:
Originally Posted by lundy View Post

Could you clarify: when you type "IBM" only into the address bar (and erase any autofill that it adds) and then hit Return, what do you get?

same result, goes to ibm.com
post #26 of 87
Thread Starter 
Quote:
Originally Posted by MagicFingers View Post

fresh/clean install of leopard here. Safari behaves the way mr. me says. As I typed in only "ibm" and hit return it went straight to ibm.com. then as I retried "ibm" it auto filled in teh .com
I guess if it doesn't work on your machine then there may be an issue, but if you are just sitting there waiting for safari to auto-fill something that doesn't seem necessary then I wouldn't know how else to help you.


I am not waiting for the autfill to come in. If I type "ibm" and then hit enter, I get an error page.

There is an issue.

It has always worked in tiger. It has never worked in any of my Windows boxes.

Tigers Safari added the ".com" after getting to the site regardless of any previous visit or bookmark. all I had to do was type the domain name (ie:ibm) and hit enter. If the site ended in .com, I would be there. It is a real time saver. If the site ended in .org, .net, etc., I would manually add it in.

I find it almost impossible to be an ISP issue, given that the issue was not present at 12:00 when using tiger, but was at 2:00 right after the Leopard install. It must be Safari related.

Someone on the Apple support forums recommended using OpenDNS, but it does not seem to correct this issue on everyone having this issue. Apparently, it is a wide-spread issue with the Leopard version of Safari. Apple is not commenting, however.
post #27 of 87
Thread Starter 
Quote:
Originally Posted by kcmac View Post

One more thing you could try but since you did a clean install I don't know if it will help or not. Either way, the following is a great utility for OS X and now it is is compatible with Leopard.

http://www.macupdate.com/info.php/id/11582/onyx

Go into the Automation tab and select everything except Repair Permissions. Then hit execute.

Also go into the cleaning tab, click on internet and then select all you want to clean. I don't usually clean cookies or form values.

Restart a couple of times after it is done and then see what you get.

I use MainMenu for OS cleaning. Since I was having these issues, I dL'd it and clean house. Then I reset Safari, deleted the plists, repaired permissions, cleared PRAM and NVRAM, restarted, tried as other user, etc. No good.

It is sort of a pain. Safari has spoiled me to the point that I hate to even use firefox. I just want this feature to work. When I type a domain and hit enter, it should take me directly to www.domain.com
post #28 of 87
OK, well since you get the wrong behavior with two different user accounts, then the misconfiguration is in the System folder or in the /Library folder.

It's just impossible to say whether it is webkit prefs, Safari prefs, input managers, text encoding, or what.

I forget it anyone advised testing starting up with extensions off. Shift-reboot.., hold Shift until desktop appears.
--Johnny
Reply
--Johnny
Reply
post #29 of 87
In my case, Safari corrects the URL if I have visited the website in the past. It does this even if I delete the autocomplete text. It doesn't work if I type in a URL that is new. Firefox does a Google search for fixing this, but I am fine with the way Safari works.
Most of us employ the Internet not to seek the best information, but rather to select information that confirms our prejudices. - Nicholas D. Kristof
Reply
Most of us employ the Internet not to seek the best information, but rather to select information that confirms our prejudices. - Nicholas D. Kristof
Reply
post #30 of 87
I think you messed up the "Search Domains" section in your network preferences. Normally you don't need to add com there but you can give it a try. Make sure there is nothing weird in the list and check the preferences for all network connections you use (e.g. AirPort and Ethernet). Quote from the Help:

The search domains you enter in your Network preferences are automatically appended to names you type in Internet applications.

For example, if you specify the search domain apple.com, typing store in your web browser takes you to store.apple.com. Or, if you use campus.university.edu as a search domain, you can type server1 in the Finders Connect To Server dialog to connect to server1.campus.university.edu.
post #31 of 87
Quote:
Originally Posted by 9secondko View Post

I am not waiting for the autfill to come in. If I type "ibm" and then hit enter, I get an error page.

There is an issue.

It has always worked in tiger. It has never worked in any of my Windows boxes.

Tigers Safari added the ".com" after getting to the site regardless of any previous visit or bookmark. all I had to do was type the domain name (ie:ibm) and hit enter. If the site ended in .com, I would be there. It is a real time saver. If the site ended in .org, .net, etc., I would manually add it in.

I find it almost impossible to be an ISP issue, given that the issue was not present at 12:00 when using tiger, but was at 2:00 right after the Leopard install. It must be Safari related.

Someone on the Apple support forums recommended using OpenDNS, but it does not seem to correct this issue on everyone having this issue. Apparently, it is a wide-spread issue with the Leopard version of Safari. Apple is not commenting, however.

I'm still running 10.4.11 (not willing to upgrade to Leopard yet until post 10.5.2, plus it gets better support from the Apps I use). You're quite right that Safari on Tiger behaves exactly as you've said. I just tried it.

For me though it's not something I ever use, as URL auto-complete takes precedence over this feature, and 99%+ of the URLs I type in directly are either in my history or in my bookmarks.
post #32 of 87
Thread Starter 
Quote:
Originally Posted by shadow View Post

I think you messed up the "Search Domains" section in your network preferences. Normally you don't need to add com there but you can give it a try. Make sure there is nothing weird in the list and check the preferences for all network connections you use (e.g. AirPort and Ethernet). Quote from the Help:

The search domains you enter in your Network preferences are automatically appended to names you type in Internet applications.

For example, if you specify the search domain apple.com, typing store in your web browser takes you to store.apple.com. Or, if you use campus.university.edu as a search domain, you can type server1 in the Finders Connect To Server dialog to connect to server1.campus.university.edu.

unfortunately, No, I never touched that section of the network prefs. I didn't alter anything. we are talking a stock, factory fresh, clean, brand new Leopard install here.
post #33 of 87
Quote:
Originally Posted by 9secondko View Post

unfortunately, No, I never touched that section of the network prefs. I didn't alter anything. we are talking a stock, factory fresh, clean, brand new Leopard install here.

Ever think of trying the WebKit Nightly Build? Go to http://webkit.org/ and download it. It's worth a shot.
Embrace your inner geek.
Reply
Embrace your inner geek.
Reply
post #34 of 87
I have the same problem, and i did an archive and install. In tiger i used to love not having to type .com. Now it takes me to a verizon search page.
post #35 of 87
Quote:
Originally Posted by 9secondko View Post

Hello,

I just recieved Leopard for Christmas and I love it.

However, one issue annoys me to no end:
In Tiger, if I wanted to go to a web address that ends in ".com" all I had to do was type the domain name. No typing "www" at the beginning or ".com" at the end. This was enabled by default.

After performing a clean (erase and install) install of Leopard, it appears that feature is gone. I cannot find it in Preferences.

Can someone help me how to reinstate this useful and time-saving feature?

Not that this helps, but I recently purchased a Mac Mini and installed Leopard, and am having the exact same annoyance that you are. Unfortunately, I have not discovered a solution. I have the same problem with Firefox, so I'm thinking the issue may be with the OS, network settings, or even ISP. I do hope we discover a solution! Good luck.
post #36 of 87
You could try Firefox for mac. It behaves the same as Safari, even in the Windows version (although the Windows version doesn't always work as well as the mac version).

By the way, in Windows this is accomplished with Ctrl+Enter after typing the domain in most browsers including IE and Firefox. Obviously just enter is easier, just FYI since you said you manage some Windows boxes.

Travis
post #37 of 87
Quote:
Originally Posted by neondiet View Post

I'm still running 10.4.11 (not willing to upgrade to Leopard yet until post 10.5.2, plus it gets better support from the Apps I use). You're quite right that Safari on Tiger behaves exactly as you've said. I just tried it.

For me though it's not something I ever use, as URL auto-complete takes precedence over this feature, and 99%+ of the URLs I type in directly are either in my history or in my bookmarks.

Perhaps the fact that .com is how it "works" is a definite departure in Leopard Safari seeing as how if I type in a university without the edu it auto appends a .com on it.

It's first and foremost been a hack.

Getting rid of hacks in WebKit is a high priority.
post #38 of 87
Thread Starter 
Quote:
Originally Posted by mdriftmeyer View Post

Perhaps the fact that .com is how it "works" is a definite departure in Leopard Safari seeing as how if I type in a university without the edu it auto appends a .com on it.

It's first and foremost been a hack.

Getting rid of hacks in WebKit is a high priority.

You call it a hack, I cal it a useful time-saving feature. If you know your intended address is a .edu, .net, .org, etc., then you can just type it in. an automatic .com entry does nothing to hinder that. It is a highly valuable tool that only helps.

It makes no sense to remove it if indeed that is what transpired here.

I don't like Firefox much as I prefer Safari, and entering keyboard commands to insert ".com" seems like as much trouble as typing it in - as firefox requires.

Though Safari uses webkit, it can also have other features added. If this one is removed, it would seem like a foolish maneuver.

While I am somewhat encouraged that I am not the only one having this issue, it bothers me that it is happening at all.

On a side note, is everyone's Leopard OS using Preview to open web PDF's? Mine asks me to choose a PDF viewer and Preview is greyed out from that select screen. I am forced to use Adobe Acroboat CS3 Pro which I have installed. This never happened in tiger.

Man, some of these changes just scream "unfinished." I was going to wait until 10.5.2, but my wife surprised me for christmas along with an iPhone (she is the best I could have ever asked for - even without the Apple stuff).

Tiger felt extremely polished to me (purchased notebook in November '05) and ran perfectly. I couldn't imagine anything better. Well, with Leopard, that dream has been shattered. There are other issues as well, but these are the highlights for me.
post #39 of 87
Quote:
Originally Posted by 9secondko View Post

You call it a hack, I cal it a useful time-saving feature. If you know your intended address is a .edu, .net, .org, etc., then you can just type it in. an automatic .com entry does nothing to hinder that. It is a highly valuable tool that only helps.

It makes no sense to remove it if indeed that is what transpired here.

I don't like Firefox much as I prefer Safari, and entering keyboard commands to insert ".com" seems like as much trouble as typing it in - as firefox requires.

Though Safari uses webkit, it can also have other features added. If this one is removed, it would seem like a foolish maneuver.

While I am somewhat encouraged that I am not the only one having this issue, it bothers me that it is happening at all.

On a side note, is everyone's Leopard OS using Preview to open web PDF's? Mine asks me to choose a PDF viewer and Preview is greyed out from that select screen. I am forced to use Adobe Acroboat CS3 Pro which I have installed. This never happened in tiger.

Man, some of these changes just scream "unfinished." I was going to wait until 10.5.2, but my wife surprised me for christmas along with an iPhone (she is the best I could have ever asked for - even without the Apple stuff).

Tiger felt extremely polished to me (purchased notebook in November '05) and ran perfectly. I couldn't imagine anything better. Well, with Leopard, that dream has been shattered. There are other issues as well, but these are the highlights for me.

It's a hack. You don't have a locally cached DNS registrar dbase to know which domain extension to append and thus they just added the .com to show a feature which is a hack but great for demos.
post #40 of 87
FWIW, I am running Leopard on Intel and Safari DOES add the .com to websites that are not in the AutoFill list. So the feature has *not* been removed. Or if it was removed, they put it back.

The only difference is that I am running the 10.5.2 developer build 9C7. The Safari build is Version 3.0.4 build 5523.15.

Is this the same Safari build that you guys who are having the problem are running?
--Johnny
Reply
--Johnny
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mac OS X
AppleInsider › Forums › Software › Mac OS X › Safari Issue - no longer adds ".com" automatically