or Connect
AppleInsider › Forums › Software › Mac Software › When sending email, outgoing SMTP server keeps being rejected on first attempt
New Posts  All Forums:Forum Nav:

When sending email, outgoing SMTP server keeps being rejected on first attempt

post #1 of 27
Thread Starter 
The SMTP server I use for sending email had been working fine up until about a week ago. Although no changes were made to my setup, now virtually every time I send an email, I get the pop-up "Cannot send message using server xxxx".

When click on "Try with selected server" (the same server), it will then usually send okay; sometimes it takes an additional attempt.

Is this some keychain issue or something?

I've deleted the SMTP server and re-entered all the info, but it's still happening.

The SMTP server is the one from my ISP, so they should be okay with it.

Any ideas?

(PS I'm running Leopard 10.5.2)
post #2 of 27
Are you using Comcast? Try smtp port 587, this drove me nuts when they messed with the port numbers here.
post #3 of 27
Thread Starter 
Quote:
Originally Posted by Sherman Homan View Post

Are you using Comcast? Try smtp port 587, this drove me nuts when they messed with the port numbers here.

Nope. I've got SBC (DSL). Really annoying....
post #4 of 27
Quote:
Originally Posted by Argelius View Post

Nope. I've got SBC (DSL). Really annoying....

I know nothing of SBC and whether it's merger with ATT has you under SBC Yahoo ADSL or not, but if you do:

http://helpme.att.net/article.php?item=285

o locate and verify your email settings in Outlook Express:

1. Click on the Tools menu in Outlook Express.
2. Click on Accounts.
3. Click on the Mail tab.
4. Select your AT&T Yahoo! email account and click on the Properties button.
5. Click on the Servers tab.
6. Verify these settings:
* For "My incoming mail server is a ____ server," the field contains POP3.
* The Incoming mail (POP3) and Outgoing mail (SMTP) fields contain the correct mail server settings.
* The Account name field contains your full AT&T Yahoo! email address (e.g., YourName@att.net).
* The box next to Log on using Secure Password Authentication is NOT checked.
* The My server requires authentication box is checked.
7. Click on the Advanced tab.
8. Verify these settings:

Note: When updating the secure sever settings, check SSL checkbox first, then update the port number setting.
* Under Outgoing mail (SMTP) should be port 465 and the box next to This server requires a secure connection (SSL) is checked.
* Under Incoming mail (POP3) should be port 995 and the box next to This server requires a secure connection (SSL) is checked.
9. Click OK.
10. Click Close.
post #5 of 27
Thread Starter 
Quote:
Originally Posted by mdriftmeyer View Post

I know nothing of SBC and whether it's merger with ATT has you under SBC Yahoo ADSL or not, but if you do:

* Under Outgoing mail (SMTP) should be port 465 and the box next to This server requires a secure connection (SSL) is checked.
* Under Incoming mail (POP3) should be port 995 and the box next to This server requires a secure connection (SSL) is checked.
9. Click OK.
10. Click Close.

Thanks. (I've got SBC yahoo, I believe). Unfortunately, the SMTP settings (465, SSL) are how I've had it set up and it's still taking 2-3 attempts to get email to send.

I've tried deleting and rebulding the outgoing server info a couple of times, but to no avail.

And for what it's worth, I'm having a similar problem on my iPhone (which has the same email accounts and settings).
post #6 of 27
If you have a google account, turn on pop in gmail and use their smtp server to see if that clears it up.
post #7 of 27
Thread Starter 
Quote:
Originally Posted by Outsider View Post

If you have a google account, turn on pop in gmail and use their smtp server to see if that clears it up.

Thanks Unfortunately, I use sbc/AT&T as my ISP.

Other people I know who are using the same SMTP settings with Mail on 10.5.2 are having no problems.

It's an odd behavior in that mail messages will send after the second or third attempt.
post #8 of 27
Quote:
Originally Posted by Argelius View Post

Thanks. (I've got SBC yahoo, I believe). Unfortunately, the SMTP settings (465, SSL) are how I've had it set up and it's still taking 2-3 attempts to get email to send.

I've tried deleting and rebulding the outgoing server info a couple of times, but to no avail.

And for what it's worth, I'm having a similar problem on my iPhone (which has the same email accounts and settings).

Try 587 and if that craps I'd drag out your SMTP certificate form KeyChain and after Restarting and connecting to your Server see if the SMTP authentication adds a new Certificate for you.

I assume you've checked to make sure none of them have expired, correct?
post #9 of 27
Thread Starter 
Quote:
Originally Posted by mdriftmeyer View Post

Try 587 and if that craps I'd drag out your SMTP certificate form KeyChain and after Restarting and connecting to your Server see if the SMTP authentication adds a new Certificate for you.

I assume you've checked to make sure none of them have expired, correct?

I don't know why I didn't think to do that. I first checked in keychain that all the certificates were trusted and not expired. Still didn't work. Then I deleted every "smtp" listing in Keychain Access and voila! All is good now.

Thanks for pointing me in the right direction!
post #10 of 27
Quote:
Originally Posted by Argelius View Post

I don't know why I didn't think to do that. I first checked in keychain that all the certificates were trusted and not expired. Still didn't work. Then I deleted every "smtp" listing in Keychain Access and voila! All is good now.

Thanks for pointing me in the right direction!

You're welcome. To me it's one of those spurious bugs in KeyChain that it doesn't periodically check for duplicates and/or expiration dates and let the user know when applications like Mail are leveraging them.
post #11 of 27
I've been dealing with this problem for over 2 weeks on my 10.5.2 laptop. Sends can fail 2, 3, 4, 5 times and then finally go through after I keep hitting try again. And then a bunch will go through fine first time. Finally called AT&T DSL support and got nowhere since it's an intermittent problem. They couldn't duplicate it. They said it's an OSX issue although the 2nd level tech guy I got through was not knowledgeable.

This just started happening on another 10.4.11 machine so I figured it's got to be AT&T but then found this thread. However, on both machine's there's no certificate for the smtp server in Keychain Access. I tried deleting the login items but no dice. Immediately failed again on my next test send.

Any other ideas or pointers?
post #12 of 27
Thread Starter 
I finally got the issue escalated to 3rd level tech support with ATT. Whomever I spoke to seemed to acknowledge it was a problem they were aware of and would get back to me "within 4 days..."

Will wait and see.
post #13 of 27
I have exactly the same issue. It just started all of a sudden on Friday (3/28). I spent an hour on the phone with my ISP (a local company, not AT&T or Comcast or Bellsouth) trying to figure out what's going on and all they could guess is that it's some kind of firewall. I'm using Leopard as well. It's very frustrating.

post #14 of 27
I'm still in Tiger and this has been driving me nuts. It seems to be worse tonight in that unlike previous days where I could get something to send after a few attempts, I can't seem to send them at all now.

Anyone have any news?
post #15 of 27
Thread Starter 
Quote:
Originally Posted by danseq View Post

I'm still in Tiger and this has been driving me nuts. It seems to be worse tonight in that unlike previous days where I could get something to send after a few attempts, I can't seem to send them at all now.

Anyone have any news?

Well, it seems to be getting worse.

In my dealings with ATT technical support, they had me switch to Port 25 with no SSL (was previusly at 465 with SSP).
That didn't really improve things -- still could send 95% of the time on the second "try again".
This morning, I can't send anything -- on either port.

This is also happening on my iPhone and a windows PC at work, so I know the issue lies with ATT.
post #16 of 27
Thread Starter 
Well, when I got up this morning, I couldn't send emails at all -- on either port 25 or 465 (with out without SSL).

Did a little researching on the internets and tried this:

smtp.mail.yahoo.com
on port 465 with SSL.

And it works!

It works now on the first send attempt. (Also works on my iPhone)

Hope this may help someone else...
post #17 of 27
Quote:
Originally Posted by Argelius View Post

Well, when I got up this morning, I couldn't send emails at all -- on either port 25 or 465 (with out without SSL).

Did a little researching on the internets and tried this:

smtp.mail.yahoo.com
on port 465 with SSL.

And it works!

It works now on the first send attempt. (Also works on my iPhone)

Hope this may help someone else...


Hurrah!! Thank you thank you! It works... both on my iphone and my regular mac mail.

Of course 1st tier tech support told me (twice) it wasn't their fault and check my other web host.

Weak.
post #18 of 27
Hello all,

I also have been having problems with the outgoing mail server through att dsl. These problems have been cross platform (mac (Tiger) & pc (windoz XP pro)) and over multiple email programs (Outlook 2003 & Mail). Even with using the correct ports and SSL settings (smtp.mail.yahoo.com on port 465 with SSL) I still get bounce backs for 3 or 4 tries and then the message finally goes through. After digging around a bit I found this page on att dsl's site.

http://help.yahoo.com/l/us/yahoo/mai...ndfrom-07.html

Essentially, you need to register all of your other email addresses with ATT in order for them to allow you to use their smtp server seemlessly. It's really a joke. Coming from Comcast Cable Modem I could use many different SMTP servers (each based on the specific email account (.mac, gmail, other pop accounts, etc). Switching DSL I was forced to use their smtp server for all of my various email accounts. Then, they change the rules on me without telling anyone and force us to register each email address through their online webmail settings. The explanation I was given by one of their tech support people is that they are changing their email system and have put these new rules in place (again, without telling anyone) to limit spam.

After I registered each of my family's 7 email accounts (only one of which is an ###@att.net) all of my email accounts work seemlessly and can send emails without getting bounce rejections.

What a bunch of hoops to jump through just to use this slow (compared to cable modem) broadband. If only it wasn't half the price of cable modem.
post #19 of 27
I reported that I had this problem on another thread, but have had no luck in fixing it. I've talked to 2nd tier at Comcast twice, checked Apple's site, read email Apple sent to fix it. NO Luck.

I've had the problem about two weeks, and I realize how important Mac Mail is to me. Going online to send email is a real pain.
ADS
Reply
ADS
Reply
post #20 of 27
I noticed that although I set the 'Authentication' field on the Outgoing Mail Server page to 'Password', it showed 'None' when I happened to go back to that page. I changed it back to 'Password' again, but this time, I typed in my User name and Password in those fields (even though it states that you don't have to do that). Server port is 587 and SSL is unchecked. As I clicked OK, all of the messages in my outgoing box went whoooosh and were sent.

Another thing I changed was the in the Description field on the Account information page. I changed it from POP account to Comcast E-Mail. I seriously doubt that made any difference, but if the above paragraph doesn't work, try adding a like description in that field.

If you try this, please let me know if it works for you. Wow! Two weeks of frustration gone.
ADS
Reply
ADS
Reply
post #21 of 27
Thread Starter 
I subsequently found out a bit more information from ATT which, I believe, has permanently (?) fixed the SMTP/mail sending problem.

I have SBC/ATT DSL and had been using smtp.sbcglobal.yahoo.com as my SMTP server. While some of the fixes noted above, helped the situation, I would still receive fairly regular "unable to send using the selected server errors."

Once I got through second-level support with ATT I found that unbeknownst to me, they had made a change that required all email domains to be used with their smtp sever to be "registered".

I went into the yahoo email address associated with my DSL service (which I had never done since I have my own email domain). There's a place there is authenticate all the emails with which you want to use ATT's SMTP server. From the yahoo email account you send an email to each of the emails you want to authenticate; these subsequently receive a code that you then enter on the yahoo mail system.

Since I did that (along with switching to smtp.att.yahoo.com (465, SSL), everything is working 100% of the time. Not sure if Comcast (or other internet providers) are doing something similar...

This link has more info about this: http://help.yahoo.com/l/us/yahoo/mai...ndfrom-07.html
post #22 of 27
After fixing the Outgoing Mail problem, I found I had another with an applet I use called MailForward. It gathers up email from Hotmail, Yahoo, etc. and brings it to my ISP, Comcast.
Comcast automatically downloads it into MacMail on my computer. I believe Entourage does that also, but I don't trust Entourage.

Anyway, I emailed MailForward because it stopped working about the same time as MacMail.

This is the reply I received:

Several of our Comcast Mail Forward users have reported that Comcast recently changed the login requirements for their SMTP server. You will need to change your settings in Mail Forward to the ones shown on our SMTP Server Settings web page:

Outgoing Mail Server (SMTP): smtp.comcast.net

SMTP Options dialog (click SMTP Options to display):
Secure Connection (SSL): ON
Authentication Type: Login
User Name: Your Comcast account user name
Password: Your Comcast account password
===================================

It's possible that other ISP's changed login requirements for their SMTP servers.
ADS
Reply
ADS
Reply
post #23 of 27
Well I was excited about the smtp server change from:

smtp.att.yahoo.com
to:
smtp.mail.yahoo.com

That's been more reliable but not 100%. Often I get sends that seem to stall and then get a "read failure" - a try or two later and it goes through but it's still a problem.
post #24 of 27
congratz man,, now ur rocking
post #25 of 27
http://www.theregister.co.uk/2008/03..._spam_filters/
Brennan and Deerfield.com are by no means alone, judging from DSLReports threads here, here and here. All these forums report a familiar pattern: people who get their email from Yahoo.com, PacBell.net, BellSouth.net, or other domain names controlled by AT&T noticed a big drop in the amount of spam beginning sometime late last week. But at the same time, many of these users also found they were unable to receive email from legitimate sources.

In addition to killing spam they have killed my ability to use my business email address with their dsl service, my problem can't send mail correctly it started in the last 1-2 weeks
my dsl service recieveing but not sending unless I hit the send button a dozen times

smtp.att.yahoo.com - port 465
pop3 third party mail.leaseorsale.biz - port 110

the problem att/yahoo will authenicate my third party incoming email address from my pop3 account to allow my mail to go out using att/yahoo even thlough the att login is varifyed.

i've tried everything. 6-8 hrs reading ,calling still no fix
post #26 of 27
i also have sbc/att dsl internet here at home and have for months been using internet email instead of my old trusty Mail.app on my powerbook g4 that i used to use when i was overseas and the internet providers just didnt give me such troubles.

i had tried to fix it in the past and got so frustrated that i always gave up! i entered "mailhost.worldnet.att.net" as my outgoing smtp server at port 465 with SSL, and i for the first time i was able to SEND an email! (from my gmail acct.)

however...while the other person successfully received it, it simply disappeared from my outbox, never even went into the Sent box and the proof that i ever wrote it is nowhere to be found. where did it go? why didn't it go into my sent box? where do i turn to fix this?

i am so lost...any help, please? im not too techy, but im tryin. thanks a lot.
post #27 of 27
I could receive but not send from Mail also for the last few days (early Dec 08) -I am using Leopard but with my Hong Kong ISP (netfront) - tried changing back to no password, then resetting back to my normal name/password again - but still failed. But resolved the problem simply by editing the outgoing mail server and setting it to "no password" at all and "whoosh" away when all my stored/failed "sent mail". Seems like I only need a password to receive and not to send email - but at least it now works
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mac Software
AppleInsider › Forums › Software › Mac Software › When sending email, outgoing SMTP server keeps being rejected on first attempt