IOmega external HDD problem

Posted:
in Current Mac Hardware edited January 2014
Periodically, my iOmega external HDD unmounts (dismounts?). Only after disconnecting and reconnecting both the power and the USB (connected to a powered hub) does the HDD mount again. This has happened about 3 times in the last 3 months. The HDD is about 2 years old and I have had no other problem with it. It works fine other than the unmounting.



Would this be an indication of a potential failure of the HDD or just an idiosyncrasy? Any suggestions?

Comments

  • Reply 1 of 2
    mr. hmr. h Posts: 4,797member
    hmmm. That does seem a bit odd.



    Presumably, since you didn't explicitly mention it, it hasn't ever unmounted in the middle of being read from or written to?



    It may be a poorly implemented power saving feature. Does the HDD spin down at the same time as unmounting?



    If you're using the drive as extra storage space, I'd say that you should back up anything important (although you should do that anyway). If you don't have another HDD to backup to, maybe this is an opportunity to buy a new external HDD and keep this misbehaving one as a backup.



    If the drive is just a backup drive already, I wouldn't worry about it too much.



    One thing to save you the trouble of disconnecting/reconnecting when it unmounts is to try "Disk Utility" found in /Applications/Utilities/. If it shows up in the list greyed out, you can click on it and then press the "mount" button in the toolbar.



    Have you tried visiting IOmega's site to look at their support stuff, or googling the product name/number?
  • Reply 2 of 2
    sequitursequitur Posts: 1,910member
    Mr. H,

    The file, about 7GB, is supposed to automatically back up (incrementally) at 1:00 am, using Carbon Copy Cloner, to the iOmega HDD. CCC log shows the HDD wasn't "available" though the HDD showed up when I had checked the side-bar around 11:30 pm.



    CCC had backed up another file, about 16GB (incrementally), to another HDD, a LaCie, at 1:30 am.



    I tried backing up the same file during the day, and the iOmega HDD worked fine both reading from and writing to. Sorry about ending the sentence with a preposition.



    The iOmega is a secondary backup, so that isn't a problem. The entire HDD is backed up incrementally to a partition in the LaCie at 2:30 am by SuperDuper.



    The iOmega HDD doesn't show up greyed out in Disk Utility when CCC log says it wasn't available. It doesn't show up at all until I disconnect and reconnect the power and the USB cables. Then, it does show up in Disk Utility - mounted.



    I haven't checked the iOmega site, but I will.



    Thanx. Your questions made me think about specifics to mention that I hadn't thought of when I first posted. Hmm, Interesting. I'm a good editor but not so good originator. I should be more careful speaking to the "Language Police".
Sign In or Register to comment.