HD access permissions are borked - seeking expert help

in Genius Bar edited January 2014
Hello all,

I recently received a phone call from my father telling me he screwed up his mac and wanted me to drop by and see if I could fix it for him. When I tried to boot it up, it went from the gray screen to the blue screen then stops completely. Apparently, he does a lot of banking on his computer and wanted to make sure it was "extra secure" (his words, not mine). From what he said, he said he right clicked on the hard drive icon on the desktop and went into Info then into the file permissions on the bottom of the info screen. He saw that under the "Others" group, it was read-only and thought it he put No Access instead, that it would be more secure . Since that was the HD, it has locked him out of his computer.

While I do own a mac myself, this kind of technical knowhow is waaaaaaaaaaay above my head. I found this (http://support.apple.com/kb/HT2963) on apple's support site that leads me to believe that it may be fixable... if you're good with Terminal. I booted up the first idea trying to fix the permissions from an OSX install disc but that didn't work. The only other possible fix, as far as I know, is to somehow go into the Terminal and edit the permissions for the hard drive and change the "Others" group to Read-only/Read&write (whatever gets it to boot up again). I think this is probably one of those things if you know what you're doing in terminal, this is a 10 second fix. Sadly, I do not.

Any suggestions besides reformatting?

note: repairing file permissions through first aid doesn't work =(


  • Reply 1 of 3
    Haven't got a solution for you(r dad), unfortunately. I'd go to Apple tech support for this.

    However, the next time your dad's Mac (or PC) needs tending, you can save yourself time, gas, and traffic aggravation, and you can give him almost instant 'service', if you and he both have FREE Teamviewer installed.

    Teamviewer is FREE cross-platform collaboration, presentation, management, and tech support (remote desktop) software. Works like a charm!
  • Reply 2 of 3
    MarvinMarvin Posts: 14,430moderator
    Boot into single user mode by holding down command-s.

    Then type the following:

    mount -uw /

    hit return and this makes your drive accessible. Then type:

    chmod a+rx /

    hit return. Then type reboot.
  • Reply 3 of 3
    Marvin - You know you are a God among men, right? Thank you, it worked like a charm. My dad was about to take it to geek squad at best buy but i told him to give me a couple days to see if anyone would know the answer. Thank you

    Rokcet Scientist - That's a really good idea and I'll talk to him about it tonight. I forgot about things like that.
Sign In or Register to comment.