Boot issue on Macbook Pro 15" Help needed

in Genius Bar edited January 2014

This is my first post. And 1 hour ago would be my first turning on a Mac . loong story short, I am trying to fix my gf's MacBook pro but the task is turning out more difficult than expected. She spilled water on the machine a year ago, I am trying to get it to a state where I can "write iphone aps", but do not have the $$$ to be getting a new system. I am pretty tech savy, but very new to macs, any guidance would be appreciated.


Mac would hang, several seconds after switch on, a message in several languages "Your computer needs to be restarted..."

This is a MacBook Pro A1226 (15" intel core2 duo)

Things I tried:

- found out about "single user mode" went in there, and ran FSCK. Everything checked out.

- purchased a Leopard Snow CD, tried booting from it, it would hang minutes later

- - purchased a new HDD and installed it. system would still hang

- heard about verbose mode. Turned it on via option+v and noticed that the system always hangs at the same place. Now I am not sure where the verbose logs are stored so I can paste them here.. but the last few lines before it hangss look like this:




Airport Link Down on en1. Reason 1 (Unspecified)

getWOW_PARAMETERS Can't set wow params Wow is not supported

getWOW_PARAMETERS Can't set wow params Wow is not supported

DSMOS has arrived

Warning internalModemSupport declares no kernal dependancies; using

Any ideas on next steps would be much appreciated. Ideally, I would like to be able to run some diagnostics from single user mode. Maybe even unplug all unnecessary devices from the mother board and try again (but it seems like almost everything is integrated ) The fact that I am able to get into single user mode gives me "hope"

thanks for your help!

Sign In or Register to comment.