Heads up! New iPhone 4 needs Mac OS v10.5.8 or later!!!

Posted:
in iPhone edited January 2014
I just got my new iPhone from Fed Ex, plugged it into my 17" 1.67 ghz Powerbook & got the message

that the new iPhone needs Mac OS v10.5.8 or higher to work. I knew that I needed the most recent

version of iTunes (9.2) but needing 10.5.8 was news to me. Does anyone remember seeing that

important piece of info in any iPhone story over the past couple months because I sure don't.



And unfortunately since my Powerbook uses the PowerPC chip I can't upgrade to 10.5.8.

[email protected]%KING G$*(%*%(*T SON OF A B%#@H!

Comments

  • Reply 1 of 3
    nvidia2008nvidia2008 Posts: 9,262member
    Hi mate I checked on my old iBook G4, I am running the latest version which *is* 10.5.8



    So you should be able to use the iPhone 4 with a PowerPC G4 Mac. Update to 10.5.8, I see iTunes 9.2 as an update for me, update to that as well.



    Good luck.
  • Reply 2 of 3
    quillzquillz Posts: 209member
    I can't imagine this being an issue for most Mac users here, who are more than likely on at least Leopard. But yeah, if your primary Mac is an older one that can't go any higher than Tiger, I guess you're screwed.



    I guess you could always set up a Windows virtual machine. Surely the iPhone 4 should work on at least XP and higher, right?
  • Reply 3 of 3
    mellomello Posts: 555member
    Quote:
    Originally Posted by nvidia2008 View Post


    Hi mate I checked on my old iBook G4, I am running the latest version which *is* 10.5.8



    So you should be able to use the iPhone 4 with a PowerPC G4 Mac. Update to 10.5.8, I see iTunes 9.2 as an update for me, update to that as well.



    Good luck.



    Well that's interesting news to hear especially when I called Apple Tech Support & the guy told me I'd

    needed to upgrade which is what I ended up doing (17" Macbook Pro). I was planning to hold

    off until at least January.
Sign In or Register to comment.