Help please - mac mini memory problems

in Genius Bar edited January 2014

I have a problem which is causing consternation to everyone I've asked, I'm hoping someone here will have a solution.

I've attempted to upgrade my Mac Mini Intel 1.5GHz RAM to the maximum of 2Gb. This in itself isn't the problem as I'm confident in "breaking into" the casing and replacing RAM - I've done it before on a G4 Mac Mini.

The problem is this: the Mac only recognises there being one 1 Gb memory module and shows the other slot as being empty. I've tried swapping the modules to no avail. It seems that whatever I do, it refuses to see more than 1Gb.

I replaced the original memory in case I might have damaged the slots (even though I was ultra-careful), and both slots show memory. So that can be discounted.

I've even had the memory replaced with two new modules just in case one was faulty, but I just get the same diagnosis.

The plot thickens!

I did a Mac hardware test which showed no faults, so I tried one more time to insert the two memory modules.

Switched on, zapped the PRAM three times - and there it was, 2Gb RAM showing!

So I reassembled the casing, switched on and......

only showing 1gb !


Sign In or Register to comment.