Topic : Apple Mail Account: Only Downloading 1 Email at a Time

in Genius Bar edited June 2015
From about three weeks ago, on only my most heavily used email account (it has around 75,000 emails in it and gets around 200 emails each day), I was only able to download 4 emails at a time. Then it would stop. I would click "Get Mail" and it would download the next 4 emails. I'd click "Get Mail" etc etc until all emails were downloaded.

I tried to find a solution, but couldn't, so I just put up with it (it was really only a pain in the butt first thing in the morning).

Then, this morning - disaster! My main account only downloads one email at a time! It shows "55 of 55 Incoming messages", then next time "55 of 55 incoming messages" etc. A new one must have arrived because now it is showing "56 out of 56" (but I still have 6 hours of emails to download).

Important info:

* Email is hosted by gmail.

* Account is setup as a POP account.

* This issue is not affecting other staff on a mac, using same domain for email. Nor is it affecting any other email accounts I have (about 16 active email accounts, including 2 others hosted by gmail).

* Mail version is 4.3

* OS is 10.6.4

* Hard drive has 83GB available

* Last week I installed an extra 2GB of ram - so it wont be a lack of ram.

* No other email accounts are affected.

* There are 20 unread emails sitting in my Gmail account waiting to be downloaded (I logged in to Google Webmail and saw them).

* I have checked the Activity Monitor for Mail and that account seems to act absolutely perfectly (if it only had 1 email to download). In other words, there is nothing in the Activity Monitor that suggests a problem.

Any suggestions would be much appreciated!

MBP 2.4GHZ, 6/320 Mac OS X (10.6.4)


  • Reply 1 of 5
    Have you tried Mailbox >> Rebuild, yet?
  • Reply 2 of 5
    You could try doing it via IMAP (which has to be turned on in gmail). You may have to delete and readd your account, or rebuild as stated above.
  • Reply 3 of 5
    dr sedr se Posts: 1member

    Here's the solution I found today:


    In "Mail…Preferences" click on "Accounts" and, after selecting the problematic account, click the "Advanced" tab.


    Check the "Remove copy from server after retrieving a message:" box.  This will not actually remove the emails on the server, as gmail's interface is what controls this.


    Save your settings on the account, and voila! Problem solved.

  • Reply 4 of 5

    After weeks of trying to figure it out, this did it.  Thanks!


    Earlier I went for help to the Apple Genius bar and the guy there had be delete all my email and re-load the entire system, which took two evenings work, and it didn't do a thing.

  • Reply 5 of 5

    THANK YOU THANK YOU.  for that solution to downloading only one email at a time.  It was making me CRAZY! and your solution worke like magic!    THANKS!

Sign In or Register to comment.