Safari Bookmarks Erased !!

in Mac Software edited January 2014
Hello, i've been googling answered to solve this problem for hours, even called Microsoft & Apple for help but nothing. i just restarted my computer. everything was normal. all bookmarks are there, i actually just added another bookmark. so then when the computer comes back on, i open safari & the bookmarks look empty. the only bookmarks are the ones that come with safari (Apple, Yahoo!, Google Maps, YouTube, Wikipedia, News, & Popular). nothing else !! all history is there from this whole week but NO BOOKMARKS !! so i googled how to restore safari bookmarks. they tell me to look for the 'bookmarks.plist' file in safari folder. i followed plenty of instructions like "File"> "Import Bookmarks" & tried to search for the file in (Users/yourUserName/Library/Safari/Bookmarks.plist) in safari but i cannot find that safari library folder folder. i tried (C\Users\\yourname\\AppData\\Roaming\\Apple Computer\\Safari\\) but i cant even find the "appdata" folder. so then apple tells me that you can only search for the bookmarks.plist folder on a mac computer... =/ so that means i wasted the whole evening looking for those folders.

now since apple & microsoft basically tell me im on my own... im becoming really desperate. i have hundreds of very important bookmarks saved that have a bunch of job listings & apartments that i really really need.

if anyone can help PLEASE reply

im going to be searching every folder on this damn computer tonight


Thanks in Advance


  • Reply 1 of 1
    hmm ok so somebody told me how to show hidden files (thank you so much!) & now i can "C\Users\\yourname\\AppData\\Roaming\\Apple Computer\\Safari" & find the bookmarks.plist file. so i went to safari 'file'> 'import bookmarks' & the file turned out to be the current bookmark file.... WITH NOTHING IN IT!! i thought i was pretty weird that the file would be 3kb but i was just so desperate =/ so i guess the question is now, where did my previous (& very big :[) bookmark file go missing ?!?!?
Sign In or Register to comment.