screensaver can not be turned off

in Genius Bar edited January 2014
I'm on 10.6.5 and find that the screensaver kicks in after a couple of minutes, despite having been set to 'never'. Energy Saver settings all to 'never' as well. It is infuriating. What gives?

This was not a problem on Tiger or Leopard.


Machine is 2007 20" iMac Core2Duo 2.16GHz, 2GB RAM, 250GB HDD


  • Reply 1 of 1
    Have you tried changing the screen saver to something other than "Never", waiting for it to kick in, waking the machine, and then changing the setting back to Never?

    Further, do you have "Hot Corners" enabled?
Sign In or Register to comment.