Macbook sleep mode in clam shell mode while using external monitor

in Genius Bar edited January 2014
So I have bluetooth devices enabled to awake my macbook, and I numerously tried turning off the screen saver and removed and plugged back in the mini display port (mini to a dvi --> LG W2361VG). It has been connected to my LG monitor for over a year and it has worked fine in clam shell and in dual monitor mode, until now that is. Each time I connect my MB to the monitor, and close the lid (wait till it goes to sleep) and try to awake thru the keyboard, the monitor turns on for 5 seconds and goes back to sleep. I found out while having monitor preferences open that when the monitor kick in, the MB thinks that the lid isn't closes ((due to showing of 2 monitors -menu on the LG and the smaller screen (MB) to the left of it)). Removing the cable and disconnecting the monitor from the power seems to be only but temporary solutions, hence it shortly happens again. Any comments would help...Thanks.



  • Reply 1 of 1
    robmrobm Posts: 1,068member
    Hi - I used to get this using my old 17" PB G4.

    Best way to set it up is - use Sys Prefs/Displays/Arrange tab to make the LG your main display device.

    Just drag the menu bar across to the LG.

    Quit Sys Prefs.

    Reboot with both displays active.

    Close your Macbook to sleep the computer.

    Give it 20 secs or so - now hit any key.

    It should wake up with the LG as the main display.

    It'll stay stable in this config until you unplug the LG to take the MacBook somewhere ...

Sign In or Register to comment.