Macbook Pro not booting with its own harddrive

in Genius Bar edited January 2014
I have a very peculiar problem here. I urge you read through it all to understand what I have done thus far.

So, I have my mid-2010 17" Macbook Pro, right? Got it back in June (third one), and all is well. Yesterday afternoon, I was skyping with a friend and she started to blur up for a long time. I told her to do all the normal stuff, but it wasn' working. My fans were running unusually fast for a video chat, so I decided to shut it down for a minute or two and restart. Well, it turns out that last shutdown was its last.

I went to restart it, and it never got past the grey screen with the Apple logo (with the spinning circle below it). I tried to boot into my Windows partition, same thing. I tried booting to the CD, same screen. I couldn't go anywhere. I tried booting into single-user mode, safe mode, verbose mode, a probably a bunch more I can't recall. Bottom line is, this thing won't boot.

So I didn't what I shouldn't have done, and removed the hard drive from my computer so I could at least back up what I needed (172GBs.. back up often, kids). While I was at it, I removed my hard drive from my Macbook and basically swapped the two. and GO FIGURE, the MBP booted without problems or errors. It was like nothing had ever happened. When I booted up the MB, it gave me a no-OS icon, so I booted from the CD-- worked fine. I wiped and installed a fresh copy of SL on it and swapped them back.

The MB is working fine (that's what I'm on at the moment), but the MBP still won't boot. The spinning circle doesn't even come up anymore. It's just the grey Apple logo screen. I did verbose and single-user mode, and they both stop at:

"Loading System\\Library\\Chaches\\\\S tatus\\Extensions.mkext..."

..and freezes. Computer unresponsive. Cannot type anything, at all. Yet, with this same hard drive in my MB, it worked fine.

I don't understand. Usually an unresponsive verbose mode means a problem in Darwin, but how could this NOT occur in another computer? I don't think it could be an update that caused this either (nor do I remember updating recently as I was up to date).

I have Best Buy's Geek Squad all-incident warranty, so it's not a problem getting it fixed. I just would like to not have to send it out for a week and a half if it's a simple fix.

P.S MBP HDD is a 500, MB is a 120. I'm not switching hahaha.

P.S.S My friend's MBP's hard drive is in the process of failing (corrupt detected in Disk Utility and SL disk cannot repair) and his CD drive failed in the same day. My PC is also on its way out, not even two years.

What is wrong with my house?


Sign In or Register to comment.