AppleTV sync problems with new computer

in iPod + iTunes + AppleTV edited January 2014
I have recently upgraded my macbookpro. I had accumulated a lot of rubbish on my old machine and it had started to play up so I didn?t use migration assistant, I just started again from scratch, installing the programmes I needed. So that I didn?t have any potential issues with registration keys I created the same username on the new machine as the old machine.

I have a rather large iTunes library (~300GB of music, videos, books and apps) with playcounts and ratings etc. so rather than installing all the files into a new library I copied my iTunes folder from the old machine to the new machine. Syncing worked with the old machine fine and all seems to work on the new computer except that I now can?t sync my 1st gen AppleTVs (2 of them). I have removed the link in the appleTV to the old computer and have tried a series of troubleshooting with the following results (same on both AppleTVs):

1.\tWhen trying to sync I get the ??.is not responding. Check that any firewall software running on this computer has been set to allow communication on port 3689." The firewall is turned off

2.\tTurn off syncing and just stream ? ?file type not supported?

3.\tReset AppleTV ? no change

4.\tFactory restore AppleTV ? no change

5.\tUnlink and relink ? no change

6.\tDelete iTunes plists ? no change

7.\tDelete iTunes application and reinstall (leaving iTunes media folder with all info in) ? no change

8.\tCreate new (non-admin) user account and see if iTunes will connect to AppleTV ? syncing and streaming both work (using a couple of TV programmes, movies and songs)

9.\tGo back to main user account, move iTunes folder with large library, delete iTunes application and plists, reinstall iTunes, imoport a couple of files into iTunes and reconnect to appleTV ? seems to work both streaming and syncing

10.\tClose iTunes, rename iTunes library and move original library back, open itunes, relink appleTV ? ?appletv is syncing? message comes up and stays there for a long time (~2 hours before I quit). When I try to sync a second time I get the port 3689 message again.

11. Repeated some of the test on Wifi, ethernet to time capsule and direct ethernet connection from appleTV to laptop - no change in results

12. On at least one occasion all was working over wifi so I thought I had solved the situation (not sure how) but when I then connected with ethernet ready to move more of the library to the appletv and got the 3689 message again.

I?m not sure how I can resolve this problem. My gut feeling is that there is a problem with one of my itunes database or xml files that might be causing the problem (or something to do with my user settings). I know a possible way round would be to start again from scratch and reimport all my files but I don?t really want to lose my ratings/playlists etc.

Has anyone got any suggestions?
Sign In or Register to comment.