login keychain corrupted?

in Genius Bar edited January 2014
Keychain is giving me a headache.

Last night things started acting funny. TimeMachine couldn't connect to the NAS I back up to complaining about passwords. I reset the password ... pointed TM to it ... still no joy.

This morning I'm typing in password to unlock the screen. No joy. This is the same password I've been using for years. Because I screen lock I type it several times a day. There's no way I forgot it.

I use the install DVD to reset that password back to what it's always been. Now when keychain tried to unlock "login" it cannot and asks for the password. Of course that doesn't work. I go thought keychain first aid. It ask for "login" password to do the repair. Now I'm in a catch 22.

Somehow or another the login keychain got corrupted. It wont set it to the user password without the old password. So I'm basically stuck.

Here's another complexity. My encrypted disk images wont open anymore. Disk util rejects the passwords independent of keychain. Once again I use the same password for everything. No chance I forgot. So IDK if those are corrupted too or if the problem with "login" keychain is messing it up.

At this point IDK what to do. Restore the system from a day old back up? Try to pull the keychain file from the backup and replace it?


  • Reply 1 of 1
    floorjackfloorjack Posts: 2,726member
    When I first passed through keychain first aid the repair failed because login wanted the password but kept rejecting it. Now it Verifies and repairs with no errors.
Sign In or Register to comment.