Need Handbrake Help!

Posted:
in Mac Software edited January 2014
Hope I am posting this in the right section. I am using handbrake to try and convert some 20GB+ MKVs to smaller sized m4v files. I was playing around with various settings and simply converting a 1-2 min clip to test the quality of these various settings. After finding a setting that worked well, I used that setting to convert the entire file. The problem is that when it shows that the file is finished, I find an m4v file that will not play on anything, not even VLC. The 1-2 min clips work fine but when I use the exact same settings on the entire file, I get the unplayable m4v. Do m4v files have a file size limit I don't know about? The completed files are coming out at right around the size I was hoping for (about 5-6GB). Any help would be appreciated.

Comments

  • Reply 1 of 4
    tallest skiltallest skil Posts: 43,399member
    Quote:
    Originally Posted by Half Nelson View Post


    I find an m4v file that will not play on anything, not even VLC.



    This happens all the time when I rip my HD DVDs and other high def content.



    I'd love an answer to this, as well.



    Let me guess, the icon preview doesn't show up (it's just the stock filetype icon) and QuickTime'll say that it doesn't know how to play a file with this format (even if it has another m4v file open at the same time), right?
  • Reply 2 of 4
    Quote:
    Originally Posted by Tallest Skil View Post


    This happens all the time when I rip my HD DVDs and other high def content.



    I'd love an answer to this, as well.



    Let me guess, the icon preview doesn't show up (it's just the stock filetype icon) and QuickTime'll say that it doesn't know how to play a file with this format (even if it has another m4v file open at the same time), right?



    Have you checked the box (in Handbrake... under "Output Settings") to allow large file sizes? I know it sounds obvious, but it's the only thing I can think of, and is apparently necessary if your final file will be greater than 4GB.

    I also get the impression, that in that case, the App you use to play the new file must be a 64 bit app. (for which, QTX should qualify, and therefore the Finder/QuickLook as well.)
  • Reply 3 of 4
    tallest skiltallest skil Posts: 43,399member
    Quote:
    Originally Posted by KingOfSomewhereHot View Post


    Have you checked the box (in Handbrake... under "Output Settings") to allow large file sizes? I know it sounds obvious, but it's the only thing I can think of, and is apparently necessary if your final file will be greater than 4GB.



    I set my files to be exactly 4GB. Sometimes they work, sometimes they refuse to. Exact same settings every time; the only difference is the content of the file.



    Ever since Snow Leopard, Handbrake still works with and reports gibibytes as gigabytes, though, so it's rather confusing getting the file sizes you want. I just type 4000 every time. *sigh*
  • Reply 4 of 4
    Quote:
    Originally Posted by KingOfSomewhereHot View Post


    Have you checked the box (in Handbrake... under "Output Settings") to allow large file sizes? I know it sounds obvious, but it's the only thing I can think of, and is apparently necessary if your final file will be greater than 4GB.

    I also get the impression, that in that case, the App you use to play the new file must be a 64 bit app. (for which, QTX should qualify, and therefore the Finder/QuickLook as well.)



    That was the fix! Thank you! M4Vs are playing now, just need to test them on iPad.
Sign In or Register to comment.