Two issues with Lion's Safari(5.1)

Posted:
in Genius Bar edited January 2014
I've got a couple issues with Safari 5.1 on Lion.



1) On launch, Safari opens the last page opened, not the homepage. Is there any way to have it open the homepage?



2) Every time I play a Flash video a window comes up to accept or deny. Problem is this window is unresponsive and I can't get rid of it regardless of what I click on it and can't be moved either. Anyone else have this problem? I could set the setting to "accept all" but that could be asking for trouble.

Thanks,

Steve

Comments

  • Reply 1 of 5
    tallest skiltallest skil Posts: 43,399member
    Quote:
    Originally Posted by macmaniac View Post


    1) On launch, Safari opens the last page opened, not the homepage. Is there any way to have it open the homepage?



    Don't leave a page up when you quit it.



    Quote:

    2) Every time I play a Flash video a window comes up to accept or deny.



    That's Flash's fault. Download the newest version of Flash and tweak its settings in System Preferences.
  • Reply 2 of 5
    macmaniacmacmaniac Posts: 180member
    That's Flash's fault. Download the newest version of Flash and tweak its settings in System Preferences.[/QUOTE]



    Thanks for your help, Skil. I have the latest version of Flash for Safari and FireFox. The problem is the "accept or deny" box doesn't respond to clicks on it and stays on my screen. The preferences for this are limited.
  • Reply 3 of 5
    tallest skiltallest skil Posts: 43,399member
    Quote:
    Originally Posted by macmaniac View Post


    Thanks for your help, Skil. I have the latest version of Flash for Safari and FireFox. The problem is the "accept or deny" box doesn't respond to clicks on it and stays on my screen. The preferences for this are limited.



    Yep, mine refuses to respond, too. Flash is terrible.



    The trick is to just allow everything without asking and after you visit your Flash content sites, wipe everything that was allowed (again in System Preferences).
  • Reply 4 of 5
    System Preferences, General, uncheck "Reopen windows when quitting and re-opening apps".
  • Reply 5 of 5
    Quote:
    Originally Posted by Jbryant705 View Post


    System Preferences, General, uncheck "Reopen windows when quitting and re-opening apps".



    That stops the action of Resume for all applications, not just Safari.
Sign In or Register to comment.