(solved) mac network connected to ADSL not working

zozo
Posted:
in Genius Bar edited January 2014
i have been helping with a small company that has an all iMac network (4 imacs and network printer) that connects through a hub to an ADSL modem. All running 9.2.2



The net provider has sold the companyy 3 IP addresses so connecting through the hub which is connected to the modem should work. Basically this is the setup:



MODEM--->(uplink)HUB<----4iMacs connected to HUB.



Supposedly everything was perfect until a month ago then things started acting up, freezes, lost network connections, etc. I have tried disconnecting the net connection onto the hub and then everything works perfectly. 3iMacs have to be on the net and also conected to the 4th iMac which is a file server. The file server iMac I have disabled TCP/IP and the others are using DHCP as they should be.



When the Macs are connected to one another for filesharing, the connections quit and sometimes freeze and cause the need for a hard restart.



So, the provider's tech guy came and said that the modem is fine... but he was blaming me for incorrectly installing the Macs (which are perfect). The guy obvioulsy had no clue how to handle a Mac.



My question... what the heck could the problem be? THe net provider says its our problem and its oviously not. The tech guy looked at the TCP/IP control panel and said it was configured properly. When the modem is taken off the hub, everything works perfectly. I'm totally lost and have run out of ideas.



[ 01-18-2002: Message edited by: ZO ]</p>

Comments

  • Reply 1 of 4
    I agree with the tech guy. It looks like your problem to me.



    If you use a different hub do the problems go away?



    If you disconnect the hub from the router do you still experience crashes while filesharing.



    Even if you weren't having these sorts of problems I'd be looking to move to a switch or a multiport router for greater speed...
  • Reply 2 of 4
    If the external modem is maintaining a DSL link to the outside, then the problem IS on the inside of the modem.
  • Reply 3 of 4
    zozo Posts: 3,115member
    I finally found out the problem...



    Basically I had to disable TCP/IP file sharing and rely on traditional AppleTalk.



    The TCP/IP filesharing and the DHCP dont mix at all... how very stupid





    If one looked at the TCP/IP control panel you could see the IP addresses continously jumping every 30 seconds or so... was crazy. Went to File Sharing control panel and unchecked the 'Enable file sharing with TCP/IP'



    Thanks for your replies anyway guys!



    ZO
  • Reply 4 of 4
    [quote]Originally posted by sizzle chest:

    <strong>If the external modem is maintaining a DSL link to the outside, then the problem IS on the inside of the modem.</strong><hr></blockquote>





    Thats not necessarily true. Just because you have a sync light to the provider doesn't mean they're running everything properly.



    I have Earthlink DSL and had a sync light for 2 weeks but couldn't get online. They finally figured out it was on their end. So just because you can connect to them doesn't mean everything is ok.
Sign In or Register to comment.