GAH! iBook problems

in Genius Bar edited January 2014
This happens every time I boot into OS 9 and restart (still in 9).

There's a flashing system folder and I have to start up off my iBook disc, but the hard drive won't mount, so I have to then restart off the 10.1 disc. If I repair my drive (with DFA on the 10.1 disc), it says nothing is wrong, but when I restart on my hard drive it still has the flashing folder. So if I boot off the iBook disc again, it will mount the drive finally and let me select it in the Startup Disk control panel and get back into X (since it makes me so pissed at 9 that I swear I'll never boot into it again...and I don't...for a while )

As you can see, this is pretty much keeping me from using OS 9... I took it to an Apple certified technician and he kept it for a week and said it worked perfectly the whole time. I took it home and it wouldn't start up again...

This also happened with with my Pismo, but never did it again after I upgraded to a 20 GB IBM Travelstar HD from the standard 6 GB HD. I don't want to upgrade my iBook hard drive now though because it voids the warrantee (which is incredibly stupid) and I don't want that, in case there are major problems.

This happens after booting from X and restarting only, but it takes about half an hour to fix it again and I don't want to do that every time I need to use 9.

Anyway, tonight something similar happened. I dialed up to the internet, and went to check my IP address in the Sharing Preferences pane as I needed to test something. I clicked on it trying to select it and all of a sudden, iTunes started playing the same 1/4 second of a song in an infinite loop and everything froze.

After waiting several minutes to no avail, I restarted. Gray screen. More gray screen. Then it had a floppy disk with a flashing question mark (different than the system folder) and the hard drive was spinning up, then suddenly shutting off, then spinning again, over and over again. (Note that this was without having OS 9 chosen in the Startup Disk pane, it was just a force restart in X which should have restarted back into X just fine) So I shut it off, pushed the reset button for 30 seconds with everything unplugged and the battery removed. Turned it back on, reset the firmware, booted off the 10.1 disc, ran DFA, it repaired a few little things, so I booted off the hard drive again. Same flashing floppy disk. Booted off iBook disc. Started up, reblessed system folder, restarted again, and it worked...

So I booted back into X and here I am.

Can anyone help me? Please?

<looks up>

Damn, I wrote a lot.


Sign In or Register to comment.