Maxtor drive troubles

in Genius Bar edited January 2014
I got a Maxtor FireWire drive Tuesday. Let me tell you the steps that I took.

Having been told that the Mac OS 9.2 should recognize FireWire drives automatically, I tried initializing the drive with the Drive Setup software from Mac OS 9.2. The "initialize" button was greyed out. I therefore installed the Maxtor drivers. When I double-clicked on the Maxtor FireWire Utility I got the following message:


No supported device found! Please install the "Maxtor FireWire Support" or "FireSCSI"driver(s) using the Maxtor installer and restart.


I did have the Maxtor FireWire Support drive installed. I tried again, however, I got the same message as above. I had to switch to Mac OS X to do something. Apple's Drive Utility ran automatically and gave me the option to initialize the drive with partitioning if I wanted (Another reason to love Mac OS X). When I initialized the drive I made sure that the "Install Mac OS 9" drivers was enabled. The drive showed up and worked perfectly in Mac OS X. I then switched back to Mac OS 9.2 and the Maxtor did not show up. I tried it with and without the Maxtor FireWire driver. Any idea on how I can get the drive to show up in Mac OS 9.2?

By the way, the Maxtor, which is supposed to be 160GBs, was really 152.4GBs. Any idea on how to reclaim the other 7.6GBs? Could it be because the drive is originally formatted for PCs?


  • Reply 1 of 1
    jutusjutus Posts: 272member
    I can only answer your last question

    The missing "disk space" has to do with the way GB are counted by hd manufacturers. Instead of counting a mb as 1024K, they count a mb as 1000K... a GB as 1000mb, etc.

    Don't worry about it.
Sign In or Register to comment.