Captive Network Assistant not working

in macOS edited January 2014
Last week I did the updates to the latest OS X on my mac Book Air (10.7.2), the Lion Recovery Update, and iPhoto. For some reason none of these were detected in the Software Update check, so I had to do them all manually.

I'm not sure when it started, but shortly after I was no longer able to connect to my works Wifi Network, which I used to do by Lion presenting a Browser login window automatically when detecting the network for me to enter my credentials. Now the window no longer appears for this, or any other similar wifi setup where a login or Acceptance of Terms is required. In some cases, entering a URL in my normal browser will get me to the needed screen. but not my work WiFi.

I have come to learn that window is the "Captive Network Assistant". I have tried killign it and re-starting it manually, rebooting, power cycling, different browsers, dropping the network from the know list and re-connecting, creating a new location, removing my wifi preferences file, re-installing the 10.7.2 update. Nothing has worked. It's as if the port or communication is somehow blocked. I have contacted my Network admins, and they said it's nothing on their end and other Mac users in the office have no problem. So, it seems to be on my end.

Short of wiping the computer and re-installing everything, does anyone have any other suggestions to try??? Thanks!


  • Reply 1 of 1
    bbwibbwi Posts: 812member
    This appears to be an issue for others as well. Wait and see if Apple acknowledges the issue... if you can. Otherwise just Time Machine your way back to 10.7
Sign In or Register to comment.