DHCP died after crash

in Genius Bar edited January 2014
This is very odd - I had the system crash on me last night (OS X 10.1.3), and ever since the crash, DHCP will not work on this machine.

It does not matter if I restart in OS 9 or OS X - still does not work. I even tried trashing the TCP/IP and open transport preferences in 9 and restarting - still won't work.

It is not the line or the dhcp server (I can plug another mac in and it works fine), I doubt it is the network card (Appletalk still works fine, as does manually setting an IP address, both in 9 and X).

I am desperately trying to avoid having to reinstall OS X, as I just spent several days getting everything loaded and set up like I like it.

Any suggestions? This is baffling



  • Reply 1 of 2
    thuh freakthuh freak Posts: 2,664member
    i just saw what i think to be this exact problem yesterday. some kid in my dorm got a new (to him, actually it was old) mac and was trying to setup the inet (through his dhcp-enabled router), and the mac wouldn't get anything from the dhcp server.

    anyway: for him the solution was specifying a search domain (OSX: System Preferences->Network->Search Domains (optional); OS9: control panels->TCP/IP->Search Domains). You can find out what the address of the search domain is from your ISP (or your work's/school's IT department). I haven't tried them, but you can try apple.com or earthlink.net (but those might be specific to earthlink users).

  • Reply 2 of 2
    fishdocfishdoc Posts: 189member
    Thanks SO much!

    Man - and to think I was in my office for hours after work last night working on this

    Thanks again - odd that I never entered that before, and it worked, but for whatever reason, my iMac is DHCPing like normal again.

Sign In or Register to comment.