iMac OpenFirmware Help! Desperate!

in Genius Bar edited January 2014
My iMac had os 9.2.2 installed with all the firmware updates when i decided to downgrade the os and then upgrade it again to refresh my system folder. I installed os 9.0 from the cd that came with the computer and then attempted to install 9.1 when it said it could not install over the processor specific os 9.0. I did not get this at all since I did not have this problem when i first upgraded to os 9.1. I had then concluded that it was the firmware and I tried holding down the programmers button during startup which then brought me to Open Firmware... it prompted me to type "mac-boot" to restart or something like "shutdown" to shut down. Since this was no hlep to me i typed "mac-boot" and hit return... the next time my machine booted it started off my os 9 software restore cd and then told me that my hard disk couldn't be recognized and should be initialized. Like hell if i'm initializing... there has to be some way out of this... since then my computer continues to boot from the cd and freezes when it gets to the desktop... loading the "CD" background and nothing but the time in the menubar... which it keeps quite nicely i must say... I leave you with this tech not from apple about open firmware... <a href=""; target="_blank"></a>; thank you


  • Reply 1 of 1
    neutrino23neutrino23 Posts: 1,560member
    I had to read this several times to try to follow what happened. I'm still puzzled.

    1. If you had 9.2 why did you need to install 9.0? I'm going from memory but I thought you needed to purchase another disk (9.1? 9.2?) before you could update to 9.2.2. In other words, you didn't have to go so far back, I think.

    2. I don't understand how you could go so far back unless you did a clean install. You normally can't install an older system over a newer one. On the other hand, doing a clean install should not cause the problems you've experienced.

    3. I don't think Open Firmware has anything to do with your difficulty. You just happened to see that the same time this trouble occurred.

    4. I'll guess that there was a disk problem somewhere around the time you tried to install 9.0. Maybe that was the reason you wanted to "refresh the systm folder"? Possibly some weird disk problem is what is hanging the boot up of the system now. Certainly, the disk is unbootable which is why the computer always defaults to the CD.

    5. What to do?

    A. Try booting with the shift key held down. It might let it ignore the disk problem. If it does, run Disk First Aid and fix the disk.

    B. I think this is a Firewire iMac. If so, it should be able to be used in Firewire disk mode. Borrow a FW equipped laptop, connect it to your iMac, power on the laptop and after it boots power on the iMac while holding down the T key. You should now have access to the disk.

    Perhaps the name got trashed. I saw one case where the name got randomized to a very long garbage string. This prevented anything from booting on the CD but I could fix it in SCSI disk mode from another computer. Painful as it is, initializing may be the only way to use the computer.
Sign In or Register to comment.