Firewire devices not working...

in Genius Bar edited January 2014
The other day I was listening to MP3's from my firewire hard drive, and all of a sudden they stopped. So I look at the desktop and the hard drive icon is no longer there, so I try unhooking the hard drive and hooking it back up and rebooting, still nothing. So I figured something got screwed up in OS X, so I booted into OS 9 and still no hard drive. At that point I reset the PRAM (CMD+Opt.+P+R) and still no hard drive, so I pushed the reset button on the back of the powerbook and still no hard drive. At this point I hooked it up to my powermac firewire port and it mounted fine in OS X.

Basically what I am trying to figure out is if it is hardware or software related, if so how can I fix it? BTW the Powerbook warranty is up as of 60-days ago.

Any advice would be appreciated.



  • Reply 1 of 2
    ebbyebby Posts: 3,110member
    Try a digital camera if you have it. Check to see if anything shows up in the apple system profiler in OS 9, (may also be in OS X, I don't know). And third, if the others don't work, try to connect it to another Mac using target disk mode. Oh, and if you have another computer, see if the drive works on it.
  • Reply 2 of 2
    ibookibook Posts: 50member
    No luck with the powerbook. I have a Powermac 7300 running MacOSX with a firewire card and it mounts fine in it, just not in the powerbook. Looks like I am stuck either getting a new logic board (apple says that's what will need to be replaced since the firewire controller is built-in), or I can get a PCMCIA Firewire card. So, does anyone know of a good firewire card?
Sign In or Register to comment.