JPEG drag and drop weirdness with Photoshop

in Genius Bar edited January 2014
When you drag and drop a jpeg onto an application's icon or alias (e.g. Photoshop or a web browser), that application should launch and open the jpeg. This is faster than the Open dialog, and is especially convenient for opening multiple files in Photoshop at once.

But this isn't working on my iMac DV. When I drag certain jpeg files over the Photoshop icon, the icon doesn't highlight, so if I drop the jpeg, it won't open; the file will just plop itself down next to the Photoshop icon. Drag and drop works with other programs, though, like ImageReady and Internet Explorer. Just not Photoshop.

First, I thought maybe this was just an issue with certain jpegs--I suspected the ones downloaded from digital cameras. Strange thing is, this works flawlessly on both my Powerbook and beige G3 with exactly the same jpeg files. I'm also running exactly the same software--OS 9.2 and Photoshop 5.5.

So then I thought maybe it was an issue with my Photoshop install, so I reinstalled it. I even completely wiped the iMac's HD and did a fully new OS 9.2 install beforehand. Drag and drop worked for awhile, but not anymore (it might have stopped working the next time I booted up, but I'm not sure).

What's going on? I use this feature ALOT and really miss it on my iMac.


  • Reply 1 of 6
    josephgjosephg Posts: 111member
    Sorry for the bump, but does anyone know?

    This is seriously vexing me, and I can't understand why it works on a TiBook and a Beige G3--but not a DV iMac--all running the same versions of Photoshop and OS 9.2
  • Reply 2 of 6
    alcimedesalcimedes Posts: 5,486member
    i have no idea. especially if it was working then basically just stopped suddenly. doesn't make a whole lot of sense, but then again, i haven't really run into much software weirdness on Macs.

    however, the one thing i have found that will cause problems are corrupted preference files. have you tried tossing the photoshop prefs and/or the drag and drop prefs?
  • Reply 3 of 6
    stroszekstroszek Posts: 801member
    Are all of the computers running the same version of the OS and the same version of Photoshop? It shouldn't matter, but I had some SERIOUS problems with 9.2, and had to go back to 9.1 in order to get any work done.

    [ 08-06-2002: Message edited by: Stroszek ]</p>
  • Reply 4 of 6
    Have you tried rebuilding the desktop? (Just in case you're not sure how--hold down the command & Option keys as you turn the computer on).
  • Reply 5 of 6
    josephgjosephg Posts: 111member
    Thanks, guys!

    I trashed the Photoshop prefs from the Photoshop folder. (I couldn't find any "drag and drop prefs"--is there such a thing?). I also rebuilt the desktop.

    Restarted, works like a charm. Hope it stays that way.

    Since this happened both times I've done clean installs, I think something happened to the Photoshop prefs when I reinstalled all the other software (scanner driver, printer driver), which I think I installed after having worked with Photoshop for awhile.

    Thanks again!
  • Reply 6 of 6
    709709 Posts: 2,016member
    [quote]Originally posted by josephg:

    <strong>When you drag and drop a jpeg onto an application's icon or alias...</strong><hr></blockquote>


    I used to have to same the same thing happen to me! That is, until I created a little folder filled with aliases (in my Apple Menu Items folder) with all my apps. I used the folder as a pop-up at the bottom of my desktop and everything was fine! Don't ask me why.

    (Damn, I miss those little pop-up folders).

Sign In or Register to comment.